Radio Not Working - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Register Home Forums Photo Gallery Garage Search Today's Posts Mark Forums Read Auto Escrow
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

YourCobalt.com is the premier Chevrolet Cobalt Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-24-2011, 10:17 AM
Newcomer
 
Join Date: Mar 2010
Posts: 34
Garage
Radio Not Working

Hey all, I saw a post a while back about radio issues and now I am having the same issue. My radio does not turn on, however the display is fine. When I click on the radio to turn it on it will show the radio station or track number but no sound comes out, occasionally just for kicks I'll hit the power button and it will randomly turn on blaring. I have checked the fuses and they are fine. Does anyone have any idea of what's going on here. It's the stock radio and it's a 2005 Cobalt
Sponsored Links
Advertisement
 
  #2  
Old 04-24-2011, 12:54 PM
BankerBalt's Avatar
Subforum Moderator
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner
Subforum Moderator


 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,622
Garage
bad wiring...
__________________
Forged L61 BW S252 Turbocharged Showoff Thread
  #3  
Old 04-24-2011, 02:49 PM
LT1R's Avatar
Contributor
 
Join Date: Oct 2009
Location: sugar grove ohio
Posts: 429
it sounds like bad speaker wiring, check behind the radio and around the speakers to make sure anything around those are not shorting out.
  #4  
Old 04-25-2011, 08:17 AM
Newcomer
 
Join Date: Mar 2010
Posts: 34
Garage
Alright thanks. I guess im going to have to pop out the radio and take the speakers out.
  #5  
Old 04-25-2011, 08:55 AM
Gooty's Avatar
Cobalt Specialist


 
Join Date: Apr 2009
Posts: 1,219
factory speakers are pretty cheap wouldnt be surprised if the two front were blown since the car is 6 years old...i replaced my front ones with aftermarket ones after one blew didnt want it with the same cheap oem one
  #6  
Old 04-25-2011, 10:30 AM
LT1R's Avatar
Contributor
 
Join Date: Oct 2009
Location: sugar grove ohio
Posts: 429
yeathe speakersare pretty cheap,mine never blew out but i went ahead and replaced all of them with good speakers and realised how cheap and crappy the stock speakerswere when i took them out
  #7  
Old 05-24-2011, 04:09 PM
Newcomer
 
Join Date: Mar 2010
Posts: 34
Garage
Hey guys I realize it's been a while, but I just got time to take out the speakers, the front right was blown (replaced it with another stock) but radio still does not work. I checked all the speakers just to be sure and still nothing. Like I said before the radio will turn on , but no sound. I can change channels put in CD's scan basically do everything except get sound. Any other ideas.?
  #8  
Old 06-02-2011, 10:06 AM
Newcomer
 
Join Date: Mar 2010
Posts: 34
Garage
So I just bought a new stock radio and I installed it and..... it's locked. Is there anyway I can unlock it or will I have to go to a dealership
Sponsored Links
Advertisement
 
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2