Blinker Giving No Sound?? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Register Home Forums Photo Gallery Garage Search Today's Posts Mark Forums Read Auto Escrow
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

YourCobalt.com is the premier Chevrolet Cobalt Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2012, 10:07 AM
Prospect
 
Join Date: Aug 2011
Posts: 32
Blinker Giving No Sound??

For some reason when my blinker- right or left- is applied it does not always give a sound. The blinker light works but the sound doesn't. Other times it randomly does give the blinker sound. Seems like it's shorting. Anyone have any advice on how I can fix it? Thank you!
Sponsored Links
Advertisement
 
  #2  
Old 07-06-2012, 10:13 AM
Forum Regular
 
Join Date: Apr 2012
Location: St. Louis, MO
Posts: 168
Garage
Probably the driver door speaker going out. Seems common on these cars and was my problem. Turn all your music to that one speaker using the radio controls and see if it plays music. All the chimes and blinker noises come out of that speaker.
  #3  
Old 07-06-2012, 11:45 AM
MP81's Avatar
Say What again!
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
Join Date: Sep 2009
Location: Washington Township, Michigan
Posts: 4,864
Send a message via ICQ to MP81 Send a message via AIM to MP81 Send a message via MSN to MP81 Send a message via Yahoo to MP81
Yep, speaker is taking a shit. Will work sometimes, other times it won't.
__________________

1986 Chevrolet Camaro IROC-Z - Wrecked/Sold
2007 Chevrolet Cobalt LT - M62 Supercharger, Ported Throttle Body, 42 lb/hr Injectors, Intense 2.9" Pulley, Cobra Heat Exchanger, SS/TC Exhaust, TTR Engine and Trans Mounts, Trifecta Tune, ZZP Header and Downpipe, '08+ FE5 Struts/Shocks, SSC Springs, FE5 Control Arms, SS/SC Front Swaybar, Powell Hardcore Rear Swaybar, 18" MSR 045s, Dunlop ZIIs, Nightshaded Tails/Side Markers, Shorty Antenna, Black Bowties, Black Grilles, Black Headlights, Dual JL 12" w1v2 Subs, A/D/S Front/Rear Speakers, G85 Recaros, Leather Rear Seats, 160 MPH Cluster.
  #4  
Old 07-06-2012, 12:40 PM
Bronxknight28's Avatar
Super Moderator


 
Join Date: Oct 2011
Location: Bronx, N.Y.
Posts: 2,539
Garage
Dont forget the toilet paper. I'm surprised my speakers haven't blown up. I play music ignorantly loud when i feel ignorant.....watch me end up turning my radio on and all my speakers dying >.>

---------- Post added at 03:40 PM ---------- Previous post was at 03:39 PM ----------

You'd think he would be back by now to see if anyone answered. Let us know the result if you have came back!
__________________
WA636R - Switchblade Silver Mt 09 Sedan LT 2.2L LAP......Auto!

MODS:Fe5 TC Shock + Struts\Moog Endlinks\YYZ V1 Springs\SC Gunmetal Wheels. Badmab Shorty Header\GMPP Performance Exhaust\ZZP 2.5 Catted DP\K&N Drop-in filter\High Flow Intake Tube. Gen4 Headlights\6K Low Beam HID\LED 3rd Brake Light\LED Turn Signals,Plate,Trunk, Dome, Reverse, Side-marker\ Debadge "LT" & GM fender badges\Shorty Antenna

Join YC.com on Facebook! Like YC.com on facebook too!
  #5  
Old 07-07-2012, 07:00 PM
Cobalt12's Avatar
Forum Regular
 
Join Date: Dec 2011
Location: VA
Posts: 153
Garage
Mine did this too until I replaced my stock speakers

...07cobalt...
  #6  
Old 07-16-2012, 06:25 AM
Prospect
 
Join Date: Aug 2011
Posts: 32
Thanks guys. Definitely is the speaker
  #7  
Old 07-16-2012, 08:07 AM
Coby7's Avatar
Super Moderator
YourCobalt.com Premium Member


 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 8,996
Garage
When you replace the speaker, be careful not to damage the water barrier inside the door.
__________________
Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2007 Cashmere metalic Cobalt LS Sedan 2.2L auto 1G1AJ55F977161789
Drives 2010 Crystal Claret Metalic Cobalt LT Sedan 2.2L auto 1G1AD5F57A7173167

Never drive faster than your guardian angel can fly
  #8  
Old 07-20-2012, 03:58 PM
Prospect
 
Join Date: Aug 2011
Posts: 32
Fixed one left front side speaker for $93 parts and labor at my dealer. I didn't have to pay for it as the car was under extended warranty.
  #9  
Old 07-20-2012, 07:30 PM
acoutu's Avatar
Expert
 
Join Date: Apr 2011
Location: Kelowna, BC
Posts: 988
Garage
what year is your car?
can anyone confirm or disprove that 05 and 06 do NOT play the chimes thru the speakers, but rather thru the speedo cluster (theres a small speaker in back)
  #10  
Old 08-14-2012, 03:55 PM
Prospect
 
Join Date: Aug 2011
Posts: 32
It is a 2008 and it was definitely the speaker
Sponsored Links
Advertisement
 
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2