Electrical help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-19-2016, 03:40 PM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 5
Electrical help

I have an 07 ls I bought a double din boss 320 watt radio followed a wire diagram I found on a website wired it up and now none of my electronics work and I can't turn my car it is a daily driver that I need running asap if anyone has any suggestions please let me know, thanks.
Small_Oranges is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-19-2016, 03:43 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,139
Garage
You probably crossed the two dark green wires, one is GMLan the other goes to a front speaker. If you did mix these you will also have a burnt fuse in the BCM fuse block. I forget which one.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2007 Cashmere metalic Cobalt LS Sedan 2.2L auto 1G1AJ55F977161789
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2011 Silver Silverado 5.3l V8 auto 1GCRKSE31BZ141724






Never drive faster than your guardian angel can fly
Coby7 is online now  
post #3 of 8 (permalink) Old 10-19-2016, 05:36 PM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 5
I'll check it out when I get home if so you just saved my life I'll let you know in a little while
Small_Oranges is offline  
 
post #4 of 8 (permalink) Old 10-20-2016, 05:08 AM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 5
RDO fuse was blown replaced it and nothing works still. We did find out my headlights, horn and etc all work it's my interior lights that don't work and my cluster doesn't turn on nor the radio or trunk button and the car will not start. But my phone charger does work in the car and it's lit up.
Small_Oranges is offline  
post #5 of 8 (permalink) Old 10-20-2016, 07:08 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,139
Garage
Check the 50 amp fuse in the trunk by the battery. Am I to understand you wired up the new radio without disconnecting the battery?


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2007 Cashmere metalic Cobalt LS Sedan 2.2L auto 1G1AJ55F977161789
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2011 Silver Silverado 5.3l V8 auto 1GCRKSE31BZ141724






Never drive faster than your guardian angel can fly
Coby7 is online now  
post #6 of 8 (permalink) Old 10-21-2016, 09:25 AM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 5
Yes I completely forgot to disconnect the battery but I still have power to certain things which is weird
Small_Oranges is offline  
post #7 of 8 (permalink) Old 10-21-2016, 09:29 AM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 5
That fuse is good
Small_Oranges is offline  
post #8 of 8 (permalink) Old 10-21-2016, 03:49 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,139
Garage
Okay, check the 2 BCM fuses in the underhood fuse block.


Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2007 Cashmere metalic Cobalt LS Sedan 2.2L auto 1G1AJ55F977161789
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2011 Silver Silverado 5.3l V8 auto 1GCRKSE31BZ141724






Never drive faster than your guardian angel can fly

Last edited by Coby7; 10-21-2016 at 04:08 PM.
Coby7 is online now  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome