"Engine Disabled" - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-29-2009, 04:22 PM Thread Starter
Cobalt Specialist
 
Join Date: Aug 2007
Location: Long Island, New York
Posts: 1,115
"Engine Disabled"



So i was sitting at a red light today, light turns green, i go to go. Car doesnt move, engine goes "putputputputput", DIc says engine power reduced, then the car stalls. Dic reads "engine Disabled" and car wouldnt start back up.

Put my hazards on cause i was in the middle of the street. Waited like 2 mins and tried again and it started up, With a check engine light though.

So i take my car to autozone and they try to pull the code. First try they said its not reading any codes, then theytry 2 more times and it finally pulls the code.

p0601
Control module ROM fault
-During power up conditions the ECM detected 3 incorrect checksums
Proable cause= Failed ECM....


Failed ECM? wtf? Now early today i was messing around with my system so i did unhook my car battery which i know resets the ECM. But it was fine all day after i hooked it back up. And once i left autozone the CEL went away and its been driving fine...

Any ideas as to what the problem could be, what i should do?

2007 Black LT coupe
35% Tint all around - Completly debadged - Side Moldings Removed
KICKER ZX 650 RMS interior amp - KICKER ZX1000 RMS Sub Amp
1 KICKER 12" L7 - All new pioneer interiors - Pioneer Avic Z2 W/ GPS
Rockford 1 Farad capcitor - Trunk, Doors, and Rear deck Dynamated - PS2 with guitar hero
Blue footwell neons - Two Alpine type S Tweeters

Engine mods:
K&N air filter
^^^RIP^^^
2006 TBSS!
xyankees214x is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-29-2009, 05:14 PM
Forum Regular
 
idontcare522's Avatar
 
Join Date: Jun 2009
Posts: 51
its because your a yankee's fan dude.


2005 cobalt ls - 2.2 L ecotec - black - debaged - airbox mod-alot more to come
idontcare522 is offline  
post #3 of 6 (permalink) Old 10-29-2009, 05:25 PM
Forum Regular
 
Join Date: Feb 2008
Posts: 60
Still under warranty? Take it in.
zoomer210 is offline  
post #4 of 6 (permalink) Old 10-29-2009, 05:36 PM
Staff Alumni
YourCobalt.com Premium Member


 
scagnetti76's Avatar
 
Join Date: Feb 2009
Location: Helena Mt
Posts: 3,700
Garage
i found this. P0601 code: no clue - A community for the GM Ecotec engine
i found mavens post interesting.....
hope it helps.
scagnetti76 is offline  
post #5 of 6 (permalink) Old 10-29-2009, 08:50 PM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
^^^ good info at the site you posted. There is not much the average person can diagnose with a P0601 -- definitely best to take it to the dealer. Did Autozone erase the code or leave it in? If they erased it I'd go back (or get your own code reader) after a few days -- even if it doesn't go into "disabled" mode again -- to see if the code sets again. If it does take it to the dealer.

Ex-Cobalt Owner
Red07SSNA is offline  
post #6 of 6 (permalink) Old 10-31-2009, 07:03 PM
Contributor


 
Ramphex's Avatar
 
Join Date: Jun 2009
Location: Poconos, PA
Posts: 462
Send a message via AIM to Ramphex
Honestly, I'd give it some time and be careful before you go out buying a new computer. I've had that happen to me a several times last summer and then it stopped and never happened again. I didn't do ANYTHING to try to resolve the problem.. well actually I did one thing but I don't think it's relevant. I took off the positive battery post in the engine bay, cleaned off all the cables and re-tightened it back up.

2010 Cobalt SS: Full Bolt-Ons, tuned. -- Sold.
2014 WW Evo GSR: S/S & Interior Package
Ramphex is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome