Turn Signals Not Ticking - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 09-19-2010, 04:22 PM Thread Starter
Forum Regular
 
JoZaY's Avatar
 
Join Date: Jun 2009
Location: sa, tx
Posts: 248
Send a message via AIM to JoZaY Send a message via Yahoo to JoZaY
Turn Signals Not Ticking

my turn signals work just fine. they light up in the dash and come on when i need them to...but for some reason the ticking noise went out. its not really a bother cuz the point is for them to just work righht? but its annoying that the ticking isnt there. im just too used to it. and i hate when people in my car tell me that i didnt use my signal when i turned cuz they didnt hear the ticking. anyone know whats up???


FULLY BOLTED AND TRIFECTA TUNED!
JoZaY is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 09-19-2010, 04:24 PM
Expert
 
Eyesore's Avatar
 
Join Date: Aug 2010
Location: Yarmouth, Nova Scotia
Posts: 911
Garage
Send a message via Yahoo to Eyesore
its the relay that makes the clicking noise, check urs to make sure its still good..think its located under the hood in the fuse panel, but don't quote me on it, it may be inside the car


Magnaflow Catback, Jet Performance Chip, B&M Shift+, 8000k bi-xenon H.I.Ds, and more
Eyesore is offline  
post #3 of 11 (permalink) Old 09-19-2010, 04:30 PM Thread Starter
Forum Regular
 
JoZaY's Avatar
 
Join Date: Jun 2009
Location: sa, tx
Posts: 248
Send a message via AIM to JoZaY Send a message via Yahoo to JoZaY
do you know the abreveation for the relay? i took a quick gander in both fuse boxes but none of them looked like they would be it.


FULLY BOLTED AND TRIFECTA TUNED!
JoZaY is offline  
post #4 of 11 (permalink) Old 09-19-2010, 07:23 PM
Forum God
 
hailcesar75's Avatar
 
Join Date: Nov 2008
Location: broooooklyn, NY
Posts: 2,969
I don't think there is anything like that in the fuse box.

Dropped Carbon Fiber SS, Project JDM

hailcesar75 is offline  
post #5 of 11 (permalink) Old 09-19-2010, 07:34 PM
Banned


 
Join Date: Feb 2009
Location: Mechancisburg, PA
Posts: 7,805
Send a message via AIM to camopaint0707
the cobalt does not have a relay, the cobalt turn signals run through the PCM in the car, the sound comes from your speaker in the front left
camopaint0707 is offline  
post #6 of 11 (permalink) Old 09-19-2010, 07:44 PM
Forum God
 
hailcesar75's Avatar
 
Join Date: Nov 2008
Location: broooooklyn, NY
Posts: 2,969
Quote:
Originally Posted by camopaint0707 View Post
the cobalt does not have a relay, the cobalt turn signals run through the PCM in the car, the sound comes from your speaker in the front left
See!! Ha ha

Dropped Carbon Fiber SS, Project JDM

hailcesar75 is offline  
post #7 of 11 (permalink) Old 09-19-2010, 09:10 PM
Cobalt Specialist
 
stickx911's Avatar
 
Join Date: Feb 2010
Location: Charlotte NC
Posts: 1,336
Garage
similar problem here, but its just my speaker gone bad.

test it by setting your radio to only play front left. no sound = toasted speaker.

stickx911 is offline  
post #8 of 11 (permalink) Old 09-20-2010, 12:32 AM
Veteran


 
dkscbalt's Avatar
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 527
Send a message via Yahoo to dkscbalt
Did you recently install an aftermarket head unit? Mine stopped working after I put my pioneer in.


Built not bought fully bolted 2.2 and Trifecta Tuned

Authorized Trifecta Reseller In Central Wisconsin

Check out my new showoff thread!!!
http://www.yourcobalt.com/forums/veh...entral-wi.html
dkscbalt is offline  
post #9 of 11 (permalink) Old 09-20-2010, 03:25 PM
Expert
 
Eyesore's Avatar
 
Join Date: Aug 2010
Location: Yarmouth, Nova Scotia
Posts: 911
Garage
Send a message via Yahoo to Eyesore
Now u know why I said Don't Quote me lol..I'm used to imports, well on my previous cars it was relays


Magnaflow Catback, Jet Performance Chip, B&M Shift+, 8000k bi-xenon H.I.Ds, and more
Eyesore is offline  
post #10 of 11 (permalink) Old 09-20-2010, 03:33 PM
Banned


 
Join Date: Feb 2009
Location: Mechancisburg, PA
Posts: 7,805
Send a message via AIM to camopaint0707
most all cars use relays and have the battery in the engine as well
camopaint0707 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome