"service Airbag" Light - Page 2 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Register Home Forums Photo Gallery Garage Search Today's Posts Mark Forums Read Auto Escrow
Problems and Service Talk about any mechanical problems you are having

YourCobalt.com is the premier Chevrolet Cobalt Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
  #11  
Old 04-03-2012, 06:39 AM
ChevyCustSvc's Avatar
Chevy Customer Service
YourCobalt.com Premium MemberVeteran
 
Join Date: Nov 2010
Posts: 745
Quote:
Originally Posted by CobaCobaltLT View Post
I checked the wires and everything seems to be fine so i made an appointment and now it comes on more frequently , sometimes every 5 minutes
I have an appointment at the dealership tomorrow, but i can certainly give you the last 8 digits of my vin (77328351)
thanks
Good morning!

I looked into your Cobalt's information, and am not seeing any open recalls on your vehicle at this time.

For your information, here are the warranty parameters (expiration is by date or mileage, whichever comes first):
Emission Select Component until 10/04/2015 or 130,150 KM
Corrosion Limited Warranty until 10/04/2013 or 160,150 KM
New Vehicle Limited Warranty until 10/04/2010 or 60,150 KM (Expired)
Powertrain Limited Warranty until 10/04/2012 or 160,150 KM

If you should like Customer Assistance at any point after your visit to the dealership, unfortunately I cannot set anything up on my end (as I am a US Customer Service Rep). However, you can get in touch with GM of Canada at 800-263-3777 (Hours: M-F 7:30am - 11:30pm, Sat 7:30am - 6:00 EST).

All the best, and still look forward to an update!
Sarah
GM Customer Service
Sponsored Links
Advertisement
 
  #12  
Old 04-03-2012, 11:33 AM
Forum Regular
 
Join Date: Jul 2011
Posts: 199
car is still in the shop...5 hours later and there only diagnosing it, its a good thing they gave me a cruze for the day, otherwise i would be stuck, not happy, i also found a TSB 2007 Chevrolet Cobalt Airbag Technical Service Bulletins (TSB) and gave that to the dealer, but it seems way to long for a diagnostic

UPDATE: cars all fixed....yet somehow they managed to get grease on the headliner...no idea how...
__________________

Everyone has different style, therefore everyone has different taste, don't like my car, don't look simple as that

Last edited by CobaCobaltLT; 04-03-2012 at 03:09 PM.
  #13  
Old 04-04-2012, 06:17 AM
ChevyCustSvc's Avatar
Chevy Customer Service
YourCobalt.com Premium MemberVeteran
 
Join Date: Nov 2010
Posts: 745
Quote:
Originally Posted by CobaCobaltLT View Post
car is still in the shop...5 hours later and there only diagnosing it, its a good thing they gave me a cruze for the day, otherwise i would be stuck, not happy, i also found a TSB 2007 Chevrolet Cobalt Airbag Technical Service Bulletins (TSB) and gave that to the dealer, but it seems way to long for a diagnostic

UPDATE: cars all fixed....yet somehow they managed to get grease on the headliner...no idea how...
I'm sorry that it may have taken a little long, and to hear that there was some grease on your headliner afterwards (if this was something you wanted to report, we can document this for you), but it's great to know that the airbag issue with your Cobalt's repaired!

All the best,
Sarah
GM Customer Service
  #14  
Old 04-05-2012, 06:27 PM
Forum Regular
 
Join Date: Jun 2010
Posts: 76
Quote:
Originally Posted by CobaCobaltLT View Post
car is still in the shop...5 hours later and there only diagnosing it, its a good thing they gave me a cruze for the day, otherwise i would be stuck, not happy, i also found a TSB 2007 Chevrolet Cobalt Airbag Technical Service Bulletins (TSB) and gave that to the dealer, but it seems way to long for a diagnostic

UPDATE: cars all fixed....yet somehow they managed to get grease on the headliner...no idea how...
Can you tell us what was the FIX for your problem...
  #15  
Old 04-10-2012, 08:53 PM
Forum Regular
 
Join Date: Jul 2011
Posts: 199
Quote:
Originally Posted by fl1000 View Post
Can you tell us what was the FIX for your problem...
yes, they told me the pin connectors or something like that to the airbag was dirty...so they cleaned them.. and thats wat costed me 150 bones
__________________

Everyone has different style, therefore everyone has different taste, don't like my car, don't look simple as that
  #16  
Old 04-10-2012, 09:50 PM
Expert
 
Join Date: Aug 2009
Posts: 924
Damn Stealership.

My car had all the ignition wires cut up, someone tried to steal it, the retard who tried to steal it cut up all the wiper/headlight/signal and some ignition wires, it cost me $700 for them just to join a few wires together, apparently they needed to reset the system too so it could learn the new key.
__________________
Old Car: Chevy Cobalt 2006 LS Sedan base (Automatic)

New Car: Chevy Impala 2011 LT Fully Loaded (Automatic)
  #17  
Old 04-19-2012, 07:14 PM
Forum Regular
 
Join Date: Jul 2011
Posts: 199
Quote:
Originally Posted by johnccc View Post
Damn Stealership.

My car had all the ignition wires cut up, someone tried to steal it, the retard who tried to steal it cut up all the wiper/headlight/signal and some ignition wires, it cost me $700 for them just to join a few wires together, apparently they needed to reset the system too so it could learn the new key.
Heres a piss off, so my car was fixed as of two weeks ago, today driving, and the "Service airbag light" came on again, but this time its on permanently, so basically they didn't do anything to permanently fix the problem only temperaroliy (sorry for grammar) and now I'm back at the dealership tomorrow where i have to book another appointment, ChevyCustSvc, if they claimed they fixed it, but have not, do i have to pay again, because I am less then happy about this
__________________

Everyone has different style, therefore everyone has different taste, don't like my car, don't look simple as that
  #18  
Old 04-21-2012, 10:54 PM
Expert
 
Join Date: Aug 2009
Posts: 924
You should not have to pay again.
Their work on your car has a warranty also.
__________________
Old Car: Chevy Cobalt 2006 LS Sedan base (Automatic)

New Car: Chevy Impala 2011 LT Fully Loaded (Automatic)
  #19  
Old 05-03-2012, 09:32 PM
Rriggs92's Avatar
Staff Alumni
 
Join Date: Mar 2012
Location: Fort Wayne, Indiana
Posts: 1,345
i also have the light on. i took both seats out after it came on and nothing seemed to be loose, so im at a loss and am going to have the dealer look at it. 85 bucks just to look plus whatever may need fixed
  #20  
Old 05-04-2012, 06:30 AM
Soaxin's Avatar
Contributor
 
Join Date: Aug 2011
Posts: 395
I have the same thing. so what I found was If I kept the seat belt pluged in on the passenger side when the car is off then kept it pluged in all the time while driving it never comes on. Then I found that one of the wires where the seat belt connects to the floor had gotten pulled so I ziptied the base of the seatbelt to a certain position and nothing came on. I bet thats your issue.
__________________

2007 SS/SC Lazer Blue Metallic. 2.90" pulley, 42# Injectors, K&N Typhoon Intake, Badmab Header, ZZP 3"dp, HPTuned, and Tsudo Muffler.
Sponsored Links
Advertisement
 
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2