AC Output OK on Defroster and Feet, but Not Front Vents - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-09-2017, 10:34 AM Thread Starter
Prospect
 
Join Date: Sep 2008
Posts: 18
AC Output OK on Defroster and Feet, but Not Front Vents

I am trying to figure out why I can get proper airflow through the defroster vents and the feet vents, but nothing from the front vents. Note: On the dial, front vents (the ones not putting out air) is to the left, feet in the top middle, and defroster to the right).

After a bit of reading online, I looked behind the dashbaord/control panel and could see a white "wheel" that moves up and down as I turn the vent dial. I have uploaded a video showing this. To me, not ever having seen how it "supposed to" look, it seems the white wheel gets a little bit stuck when turning the dial to front vents. Air continues to flow out of the feet vents as it seems the wheel cannot shift over to front vents all the way.

Please see the video here: https://youtu.be/nYct0jOJQ8s

This is on a 2007 Cobalt. Any suggestions? Also, does anyone know the name of this piece?

Thanks!

Last edited by darthsmozers; 04-10-2017 at 10:41 AM. Reason: Took a video of the potential issue.
darthsmozers is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-14-2017, 04:36 PM Thread Starter
Prospect
 
Join Date: Sep 2008
Posts: 18
Does no one know the name of this rotating white piece?
darthsmozers is offline  
post #3 of 5 (permalink) Old 04-15-2017, 12:24 PM
Forum Regular
 
Join Date: Jul 2016
Posts: 181
Cant say what cheby calls them, however, that is part of the HvAC register cam assembly,
You will find 2 diverter valve motors there. Verify both of the motors are working.


Easy enough to remove the motors....2 screws & 1 electrical connector
Check the shaft on the lower motor..... I have a nasty feeling you might have a broken shaft there.

@Coby7
1966tbird is offline  
 
post #4 of 5 (permalink) Old 04-18-2017, 03:54 AM Thread Starter
Prospect
 
Join Date: Sep 2008
Posts: 18
Quote:
Originally Posted by 1966tbird View Post
Cant say what cheby calls them, however, that is part of the HvAC register cam assembly,
You will find 2 diverter valve motors there. Verify both of the motors are working.


Easy enough to remove the motors....2 screws & 1 electrical connector
Check the shaft on the lower motor..... I have a nasty feeling you might have a broken shaft there.

@Coby7
Thank you.
So today after driving for about 20 minutes I could hear it struggling and finally rotating all the way to give me air out of the front vents. Its as if something is gummed up and making it stick, only to release after awhile.
darthsmozers is offline  
post #5 of 5 (permalink) Old 04-19-2017, 09:07 PM
Forum Regular
 
Join Date: Jul 2016
Posts: 181
Dart
Congrats and good luck on that lower motors shaft.
1966tbird is offline  
Sponsored Links
Advertisement
 
Reply

Tags
output , vent

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome