TC & ABS Warning Lights - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-19-2009, 08:34 AM Thread Starter
Newcomer
 
Join Date: Sep 2009
Posts: 6
TC & ABS Warning Lights

I was driving yesterday when all of a sudden my car dinged and my TC and ABS warning lights came on.
I read in the manual about the Traction Control light and ABS light and didn't find it to be too much help.

If I turn the car off and back on, the lights might come on instantly or it could be a few minutes. Other times they won't come on until after I have been driving for some time. I don't feel any difference in braking or driving when they are on.

I just had the control arms changed about 1 month ago so don't know if that could have affected it.

Any help?
ahol2985 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-19-2009, 09:39 AM
Expert


 
bsbllscnd970's Avatar
 
Join Date: Nov 2009
Location: Norman, OK
Posts: 872
Garage
i have the same issue and i have no clue how it happened. mine started doing it a few weeks after i installed springs...so idk if that has anything to do w/ it.

bump for answers


07 Laser Blue LT Sedan
My Car Domain:http://www.cardomain.com/ride/3805600
4 Doors = More Whores
bsbllscnd970 is offline  
post #3 of 8 (permalink) Old 11-19-2009, 09:49 AM
Veteran
 
JDBALT06's Avatar
 
Join Date: Mar 2009
Location: Yucaipa,CA
Posts: 618
call chevy dealer to see how to reset them or something
JDBALT06 is offline  
post #4 of 8 (permalink) Old 11-19-2009, 10:07 AM
Forum God


 
09-Cobalt-lt's Avatar
 
Join Date: Aug 2009
Location: North Vancouver, B.C.
Posts: 2,625
take it in and just get them to take a look at it if your not sure. I haven't had any warning lights yet so im no help but it might be as simple as resetting it or you might actually have an issue
09-Cobalt-lt is offline  
post #5 of 8 (permalink) Old 11-19-2009, 11:35 PM
Expert


 
bsbllscnd970's Avatar
 
Join Date: Nov 2009
Location: Norman, OK
Posts: 872
Garage
no its not a resetting issue, cuz ive done that many times. it just showed up about a week after i installed my springs...i have no clue wat it is. however i kno the body shop i took my car to is going to fix it, since my accident was suspension related (but i didnt tell them it was an issue beforehand, lol). so ill ask them when i get it back wat the issue seemed to be and that might provide some answers.


07 Laser Blue LT Sedan
My Car Domain:http://www.cardomain.com/ride/3805600
4 Doors = More Whores
bsbllscnd970 is offline  
post #6 of 8 (permalink) Old 11-20-2009, 08:18 AM Thread Starter
Newcomer
 
Join Date: Sep 2009
Posts: 6
Would Autozone be able to hook up their tester and be able to tell me the problem?
The dealership will charge me about $100 dollars to hook theirs up, even if it just needs to be reset
ahol2985 is offline  
post #7 of 8 (permalink) Old 11-20-2009, 08:47 AM
Contributor


 
dondiego's Avatar
 
Join Date: Jun 2009
Location: Boston
Posts: 498
Yes AutoZone does it for free. I gave myself a tester for Christmas last year so I do it fro free at my house too



Shorty Antenna, Painted Calipers, SAI K&N Intake, B&G Lowering Springs, FE5 Shocks and Struts, Moog End Links, Moog Tie Rod Ends, Polk Audio DXi650 Speakers - front and back.
dondiego is offline  
post #8 of 8 (permalink) Old 11-20-2009, 02:44 PM
Cobalt Master
 
NitroheadZ28's Avatar
 
Join Date: Aug 2009
Location: Bk, NY- USA
Posts: 1,648
Garage
Had the same issue when my Cobalt was brand new, cept it was only affecting the traction control.. Basically, one of the wires for TC got crimped/cut by one of the springs in the rear, disabling it.. It sounds like thats what happened to bsbllscnd970 since he had the issue when he installed his springs.

Tom.

^^<==---___-A_m_e_r_i_c_a_n M_u_s_c_l_e-___---==>^^
NitroheadZ28 is offline  
Sponsored Links
Advertisement
 
Closed Thread
Gear in this thread - Powered by O'Reilly Auto Parts

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome