speaker problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-30-2009, 08:33 PM Thread Starter
Banned


 
Join Date: Feb 2009
Location: Mechancisburg, PA
Posts: 7,805
Send a message via AIM to camopaint0707
speaker problem

i have a 2007 cobalt ls, i found out that cobalts do not have a flasher relay but rather it is controlled by the BCU, and the sound of the click goes through the front speaker, recently that speaker just died, just up and died. I had to replace it and the new speakers work fine, anyone else have this problem



camopaint0707 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-30-2009, 08:35 PM
 
Join Date: May 2009
Location: Seattle Washington
Posts: 416
I've replaced my front speakers and still hear the turn signal...Sounds like the "click" is coming from my dash, not the speakers.
TheDarkened is offline  
post #3 of 5 (permalink) Old 06-30-2009, 09:09 PM
Cobalt Specialist


 
Nosfuratu9's Avatar
 
Join Date: Apr 2009
Location: Tx
Posts: 1,442
Garage
speaker may not have blown out at all, could be the wiring harness because i know when i put my aftermarket radio in i could have paid $120 for the wiring harness that makes the door sounds or $40 for the one that doesnt...i chose the one that doesnt.
Nosfuratu9 is offline  
 
post #4 of 5 (permalink) Old 06-30-2009, 09:31 PM Thread Starter
Banned


 
Join Date: Feb 2009
Location: Mechancisburg, PA
Posts: 7,805
Send a message via AIM to camopaint0707
the wires from the speaker were good cause they work on other speakers, and yes the cobalts sound does come from the speakers as they are wired to a computer not a flasher relay, that is what gm told me at least and it makes sense, eveything works fine now with a new speaker



camopaint0707 is offline  
post #5 of 5 (permalink) Old 06-30-2009, 10:04 PM
Veteran
 
burzumaske20's Avatar
 
Join Date: Dec 2007
Posts: 594
bend the pins a little and try it that way,I had that issue from the oem pioneer from ss/sc.Now they work again from bending the two metal pins a little.

2006 Chevy Cobalt LT
Synthetic oil
K&N air intake system
Custom 2.5" dynomax exhaust system
B&M shiftplus
B&M tranny cooler
Catless Downpipe
stainless steel pacesetter header
5900k light bulbs
2.4 intake manifold
burzumaske20 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome