Infinity Basslink 2 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-20-2009, 05:41 PM Thread Starter
Newcomer
 
Join Date: Jul 2009
Posts: 2
Infinity Basslink 2

So I bought a Basslink 2 powered subwoofer for my car, an LT sedan, and I am having some problems. I thought it'd be easy. THe sub comes with speaker level inputs on it, as well as RCA. With both, the subwoofer turns on but intermittentely, and favors staying on when the volume is low on my stock headunit. Any idea whats going on?

It seems like maybe the sub has an auto shutoff if it is not being supplied the correct amount of power? Any ideas or suggestions are greatly greatly appreciated. Sadly this sub is past its return date. So don't tell me it's broken...Ill be pissed
Krypto1341 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-20-2009, 06:09 PM
Cobalt Specialist


 
Nosfuratu9's Avatar
 
Join Date: Apr 2009
Location: Tx
Posts: 1,442
Garage
sounds like the ohms are messed up.
Nosfuratu9 is offline  
post #3 of 3 (permalink) Old 07-20-2009, 06:37 PM
Veteran
 
07CobaltLS's Avatar
 
Join Date: Jun 2007
Location: Coon Rapids, MN
Posts: 720
Do you have a remote lead (blue wire) hooked up anywhere or does the Basslink use an internal on/off switch?

How do you have it hooked up? Are you using a Line Out Converter or the speaker level inputs on it? You've tried both is what it sounds like in the way you're wording it.

I guess I don't really understand what you're saying in the post. You say it favors staying on when there's low volume, but then you say it might have an auto shutoff when not being supplied enough power...Is it only on with low volume or does it work when you turn the volume up?

I'm not familiar with that unit, so at the moment, without more info, I can't help you. I have an MTX X Thunderlink and it's super easy to get running.

I used a line out converter spliced into one of the rear speakers for signal. I then did the remote lead (blue wire)...connected it to the fuse box in the cabin. Lastly, power and ground.

-Mike
|07' LS Sedan|Ultra Silver|Auto|MTX X Thunderlink|Debadged|35% Tint|Sportlines|Injen CAI|ARK Antenna|ARK STB| OTTP "Street" bar|Bridgestone Potenza RE960AS Pole Position 205-60-15|Hawk PC pads|PowerSlot Slotted rotors|


Not installed yet: Pacesetter Header|Exhaust Depot DP|LSJ Cat-Back|Injen Hydroshield|MSR 045 18x8 Black w/ Red Pinstripe
07CobaltLS is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome