New HU Harness Requirements - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-19-2013, 09:17 PM Thread Starter
Newcomer
 
dwol2010's Avatar
 
Join Date: Jul 2013
Location: Rotterdam, NY
Posts: 15
Garage
New HU Harness Requirements

I'm looking to install THIS PIONEER HU into my 2006 SS without on-star. When I go to checkout on crutchfield they tell me that without the $90 harnesses they offer I will lose the Driver Info Center (Which I believe is the ODO, MPG, Trip, etc...) and the RAP and alarms. I've received these warnings for every HU I choose so someone else must have come across it.

I can deal without the alarms since most come from under the dash anyway, not the speakers. Its the D.I.C. I'm worried about.

Do I need the harnesses they're talking about or not? They almost total to the cost of the HU itself....




(Sorry if this has already been covered but I don't believe it has.. I've been looking through for quite some time now..)

Last edited by dwol2010; 07-19-2013 at 09:20 PM.
dwol2010 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-26-2013, 08:26 AM
Forum Regular
 
kateee's Avatar
 
Join Date: Sep 2011
Location: Tacoma
Posts: 235
I just installed the Metra 2103 harness on my 2005 and everything works perfect. I didn't lose Driver info, chimes, or sub and speaker use. Only thing I lost was radio controls on my steering wheel but you can get that Pac SWIx harness for forty bucks on amazon.

Kate

'08 hatch Subie owner now
kateee is offline  
post #3 of 4 (permalink) Old 07-27-2013, 10:19 AM Thread Starter
Newcomer
 
dwol2010's Avatar
 
Join Date: Jul 2013
Location: Rotterdam, NY
Posts: 15
Garage
Quote:
Originally Posted by kateee View Post
I just installed the Metra 2103 harness on my 2005 and everything works perfect.
Can you post a pic of the plug and where the wires go into the harness. I got it in and wired it all up but no power to the unit. The only thing I don't have hooked up is the red wire that comes from the hu plug itself. It may be that but it may be that I have the wrong harness. It fits in and clips on but the wires might be in the wrong ports...

/// 2006 /// SS /// Victory-Red /// 5-Speed ///

Interior:
...Red and Black Interior trim (why did chevy think tan==good?)
...Pioneer DEH-X6500BT HU
...Sound Ordinance M-1350 750W Amp
...12" Kicker Comp Sub
Exterior:
...Black 5" fender flares
...Third Break Light Stencil "COBALT"
Engine:
...None...YET!!!!
dwol2010 is offline  
 
post #4 of 4 (permalink) Old 07-28-2013, 10:38 AM
Forum Regular
 
kateee's Avatar
 
Join Date: Sep 2011
Location: Tacoma
Posts: 235
Which exact harness did you buy? If it's Metra 2103, it's correct, and here is how I did mine.

So, the harness that came with your stereo you plug that into the back of the stereo. The Aftermarket Metra harness you plug into the existing radio harness (which is the one that plugs right in) then you crimp the wires from the new stereo harness to the metra one. Just match all wires equally, except I had to match a solid blue with a blue and white to get sound.

For the red wire, you should have gotten a pinkish/red unattached wire with the metra harness. You have to crimp that, then tap into the cabin fuse box (I used sunroof, 20, you can find it's location in the manual.)


Kate

'08 hatch Subie owner now
kateee is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome