New Owner/a Few Questions... - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Audio/Video Talk about Chevy Cobalt Audio/Video and other mobile electronics here

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-05-2018, 02:51 PM Thread Starter
Newcomer
 
Join Date: Jan 2018
Location: Ripon, Wisconsin
Posts: 7
New Owner/a Few Questions...

Hello,

This will be my first post on here so let me know if I did anything wrong! :p My parents are buying a new car so they will be giving me there 2010 Cobalt(I can finally get rid of my 2001 exploder lol) and I have a few questions about this car. I believe the car is an LS model, it doesn't say LS on the trunk but when I registered the car on Mycarfax.com, it said it was the LS model. As of right now it just has the factory radio with an aux port and I found another factory radio on Ebay for $150 that has the USB port on it. The seller states that it is brand new so are those plug and play? I've been reading that if you put a used radio in, that you need to have it unlocked professionally so I didn't know if that applied with a brand new one. I have an after market head unit in my Explorer I could just throw in there, but I like to keep the factory look in most vehicles I have owned.

Next thing, both of the back speakers stopped working at the same time so I was wondering if there are known wiring issues with the cobalt? My brother has a 2008 HHR and both his rear door speakers did the same thing and I helped him swap out with a set of used speakers and they cut in and out if you wiggled the speaker wire around so I figured maybe this was common in GM vehicles?

Last thing, I was looking at adding steering wheel controls for radio control if the wiring is there. Are these plug and play also? I've been reading that the cruise has to be activated at the dealership but I was hoping the audio controls would just work automatically. I've been seeing mixed posts about this.

I don't know a whole lot about the vehicle yet since I won't be getting it for a month or so.
It's the most basic 2010 vehicle I've been in lol. It doesn't have power locks/windows, cruise control/radio controls and it doesn't even have the center arm rest/storage....yet it has onstar! But I love it and free is free!!!

This vehicle is an automatic, not sure if that matters with the features I will be toying with.


Thanks much!!
JOETOGO90 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome