Shift lever Indicator Recall 09041 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-13-2009, 05:26 PM Thread Starter
Forum Regular
 
zbhover's Avatar
 
Join Date: Apr 2009
Location: Glasford, IL
Posts: 83
Garage
Send a message via Yahoo to zbhover
Shift lever Indicator Recall 09041

I just got a recall notice in the mail today for our 09 cobalts...........

It says:
09041 shift lever indicator may not display correct gear.

I haven't noticed a problem (yet) but then again I don't usually look at the shift indicator. I really don't think it would ever be an issue for me, but I could see my wife not paying attention and think its in drive because the indicator says so when its really in reverse.

So it looks like after only having them for a month they'll already have to be going back to the dealer........... Hopefully this isn't a sign that I'll have TONS of problems like I did in the 06 G6 that I traded in for my cobalt..... I guess we'll see.

Does anyone know if it only effects certain models or???? I'd hate to take the time off of work to drop off 2 cars at the dealer and have it turn out that they aren't effected.............

Talk to you all later


bye

Zach Bell
www.zbcreations.com



"Life is not a journey to the grave with the intention of arriving safely in a pretty and well preserved body.... Rather it is to skid in broadside, thoroughly used up, totally worn out, and loudly proclaiming, WOW WHAT A RIDE!"
zbhover is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-13-2009, 05:34 PM
Forum Regular
 
Quahogmafia's Avatar
 
Join Date: Oct 2008
Location: Baltimore MD
Posts: 89
Garage
Send a message via AIM to Quahogmafia
My friend had so many problems with his 06 G6 gt he ended up trading it in for a Dodge. They only gave him 3700 for the car and he owed 13000 But he didnt care he was tired of the cars issues. Hopefully everything works out with your balt. P.S. Dont park behind your wife :-P

07 LT Magnaflow catback, Debadged, Interior trim paint, Windows tinted, Halo/Projectors on, 2/2.5 springs on, De-trimmed, 17" Konig Forwards, K&N SRI Flat black Pipe.
Soon to come Shorty Ant, Maybe a new sound system when I get the funds together

Last edited by Quahogmafia; 05-13-2009 at 05:35 PM. Reason: I cant spell
Quahogmafia is offline  
post #3 of 9 (permalink) Old 05-13-2009, 06:00 PM Thread Starter
Forum Regular
 
zbhover's Avatar
 
Join Date: Apr 2009
Location: Glasford, IL
Posts: 83
Garage
Send a message via Yahoo to zbhover
Angry

Yeah I bought an 06 G6 V6 4 door brand new and babied the car and had tons of problems......

After having it about 6 months the problems all started...... Reflector fell off of the door and broke, light on fog light switch stop working, all the bolts in both front doors were coming loose, the drivers door actually came un aligned and started leaking water, and the radio stopped working.......... They fixed all that stuff.......

Then it kept over cranking when you started it a couple months later. They reprogramed it and it didn't do it as much but still would occasionally till the day I sold it......... It actually did it the last time I started it at the dealer before I traded it in.

Then a couple other smaller things here and there.

Then TONS of steering clunk problems....... They replaced the steering column, and it started doing it again the very next day. I bought it back they said it was another bad column but had to order one. A week later they got it in so I bought the car back in and they told me that they "just" forgot to tighten the bolts on the column........ After that it still didn't fix it so I called and filled a complaint with GM............ After another column, tie rod, and a lot of BS I found a service bulletin for the exact problem. They tried it a couple times and that didn't work either......

Finally told GM I called the BBB and my lawyer was going to be calling the next day (I just made that up at the time LOL) they finally said to give the dealer one last chance and they'd send a tech up to look at it with them. They replaced the steering gear and it finally went away. I know this was partially due to a crappy service dept. (btw don't ever go to Neil Norton's in peoria, IL)

Then my speedo and gauge cluster would randomly turn from MPH to KPH. I took it to the dealer and they "said" they couldn't find a problem, but it never had a problem after I took it in.

Then about 6 months after the steering clunk, it started again, they said that every 20000 miles or so I'd have to spray grease on the intermediate steering column.

Then a few days before my warranty went out I started getting a clunk in the drivers side front end whenever it was cold out............ I took in into the dealer several times and they couldn't hear it..... Turns out they'd leave it park inside in the warmth all day then look at it......... EEEERRRR THey finally hurd it but couldn't find a problem.......

Then a month ago @ about 72,000 miles a front wheel bearing went out. At this point I was just pissed off at the car and that same day I got an email from my GM car saying I had a grand built up on it to use towards a new car.......... I was hesitant to get another GM, but I've always been kind of a GM guy, but I couldn't pass up a brand new cobalt for $9500 before taxes.........................

Like I said hopefully I have better luck................. Or It will be my last gm... LOL


Talk to you later


bye

Zach Bell
www.zbcreations.com



"Life is not a journey to the grave with the intention of arriving safely in a pretty and well preserved body.... Rather it is to skid in broadside, thoroughly used up, totally worn out, and loudly proclaiming, WOW WHAT A RIDE!"
zbhover is offline  
post #4 of 9 (permalink) Old 05-13-2009, 07:27 PM


 
Join Date: Apr 2008
Posts: 1,559
Garage
sheesh everyone has so many problems but i dont have any
Powered By LE5 is offline  
post #5 of 9 (permalink) Old 05-13-2009, 07:35 PM
Admin


 
Admin's Avatar
 
Join Date: Oct 2004
Location: Southern California
Posts: 1,651
Garage
Admin is offline  
post #6 of 9 (permalink) Old 05-13-2009, 07:38 PM
Admin


 
Admin's Avatar
 
Join Date: Oct 2004
Location: Southern California
Posts: 1,651
Garage
Admin is offline  
post #7 of 9 (permalink) Old 05-14-2009, 06:12 AM
OBZ
Staff AlumniDedicated


 
OBZ's Avatar
 
Join Date: May 2006
Location: S.L.C. UT.
Posts: 3,006
LOL admin owns!



"A wise man speaks because he has something to say,
A fool speaks because he has to say something"
OBZ's showoff thread!
OBZ is offline  
post #8 of 9 (permalink) Old 05-14-2009, 10:26 AM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
LoL!!! But...most of CC08's car problems are self induced....not the Cobalt's fault...LoL!

Ex-Cobalt Owner
Red07SSNA is offline  
post #9 of 9 (permalink) Old 05-15-2009, 08:00 AM
Newcomer
 
Join Date: May 2009
Location: Denver
Posts: 7
My 09 starte having this shift indicator problem two months after I bought it. It shows it is stuck in between reverse and nuetral or something like that. I bought it in September but I haven't bothered to get it fixed yet, it's not that big of a problem.
SpaceKitty is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome