service airbag - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-19-2009, 06:38 AM Thread Starter
Newcomer
 
Join Date: May 2009
Posts: 6
service airbag

Not sure if this is the right forum, but my wife's 07 cobalt has started showing "service airbag" When it comes on the drivers side airbag light comes on. I read another post on here stating the ground wire on the passenger side door post, but they said the passenger side airbag light would go off. On mine the passenger side seems fine. I have an Innova 1303 scantool, but it shows no codes, I'm not sure what models will pull the airbag codes. Any help would be greatly appreciated.

thanks
michael0584 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-19-2009, 08:09 AM
Staff Alumni


 
biniecki's Avatar
 
Join Date: Jan 2006
Location: Michigan
Posts: 750
Garage
Send a message via MSN to biniecki Send a message via Yahoo to biniecki
If the car is still under warranty take it to the dealership. I think I may have seen a recall or TB for this issue

2006 Cobalt LS 2.2L Ecotec
Show Off Thread




hailcesar quote - "I think you got the best transformation from Ls to badass!!!!!!!!!!!!!!"
biniecki is offline  
post #3 of 7 (permalink) Old 05-19-2009, 04:15 PM Thread Starter
Newcomer
 
Join Date: May 2009
Posts: 6
Its out of warranty
michael0584 is offline  
post #4 of 7 (permalink) Old 05-19-2009, 08:49 PM
Cobalt Master
 
Join Date: Nov 2006
Posts: 1,538
check the driver's side ground then, there is one for it too
cobaltkrazy is offline  
post #5 of 7 (permalink) Old 05-22-2009, 12:55 PM
Forum Regular
 
goodoldjr's Avatar
 
Join Date: Feb 2009
Location: Yadkinville, NC
Posts: 63
Garage
Mine did that around the first of the year, but after about a month it quit doing it (service airbag) and hasn't done it since.
goodoldjr is offline  
post #6 of 7 (permalink) Old 05-24-2009, 09:23 AM
Contributor
 
Join Date: Oct 2008
Posts: 324
try this it worked for me theres two fuses in the car fuse compartment dealing with the airbag remove them both then put them back in make sure its both of them see if that will work i had that light come and go on me and i tried that and i havent had it come on again since
shanksbaby is offline  
post #7 of 7 (permalink) Old 05-31-2009, 07:17 PM Thread Starter
Newcomer
 
Join Date: May 2009
Posts: 6
tried the fuses but no luck. Someone told me its a problem with the seatbelt? but I don't know how that would cause it.
michael0584 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome