Need Some Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-20-2010, 01:23 PM Thread Starter
Newcomer
 
Join Date: Aug 2009
Location: ohio
Posts: 24
Need Some Help

can someone tell me where the coolant temperature sensor is located. engine light came on and put it on computer and said coolant temperature sensor was below normal. the part is only 12.99 to buy i just hope i can put it on and not have to pay for it. around here they charge an arm and a leg
breeze is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-20-2010, 01:46 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Quote:
Originally Posted by breeze View Post
can someone tell me where the coolant temperature sensor is located. engine light came on and put it on computer and said coolant temperature sensor was below normal. the part is only 12.99 to buy i just hope i can put it on and not have to pay for it. around here they charge an arm and a leg
You have a 2.2 right.....if so give me a second and i'll go snap a pic for ya

---------- Post added at 04:46 PM ---------- Previous post was at 04:27 PM ----------

Kinda hard to take a picture but i found this...







XFE is offline  
post #3 of 10 (permalink) Old 01-20-2010, 04:05 PM Thread Starter
Newcomer
 
Join Date: Aug 2009
Location: ohio
Posts: 24
yea its an 05 base 2.2 my bad. i am on my cell right now and cant make those pics out i will try to get to my pc tomorrow. thank you very much for those.
breeze is offline  
post #4 of 10 (permalink) Old 01-20-2010, 08:14 PM Thread Starter
Newcomer
 
Join Date: Aug 2009
Location: ohio
Posts: 24
i have a stupid question. do the cobalts actually display a code on thee dic ? this is the second time with my engine light. auto zone said the first time the cel came on it was cause fuel running too lean.i put fuel dry and injector cleaner in and fixed then a week ago it came on and never went out so they showed me the reading. but for these problems i have not seen a code come up. is this bad?
breeze is offline  
post #5 of 10 (permalink) Old 01-21-2010, 07:26 AM Thread Starter
Newcomer
 
Join Date: Aug 2009
Location: ohio
Posts: 24
i have been doing some research on the net and seems like half the people with my problem is being caused by thermostat and not the sensor. can anyone help me figure which one it is?
breeze is offline  
post #6 of 10 (permalink) Old 01-21-2010, 07:38 AM
Forum God
 
hailcesar75's Avatar
 
Join Date: Nov 2008
Location: broooooklyn, NY
Posts: 2,969
The sensor is right under the exhaust manifold and to the right. It sticks out towards the back

Dropped Carbon Fiber SS, Project JDM

hailcesar75 is offline  
post #7 of 10 (permalink) Old 01-21-2010, 08:23 AM
Expert
 
Join Date: Feb 2008
Location: Edmond
Posts: 869
There isn't much anyone can do for this concern without a proper scan tool and more information. no the code won't be displayed on the DIC. Who would even know what it means? Normally it is a thermostat concern, either stuck open or stuck closed.
BlackBaltSS is offline  
post #8 of 10 (permalink) Old 01-21-2010, 12:02 PM Thread Starter
Newcomer
 
Join Date: Aug 2009
Location: ohio
Posts: 24
i took it to autozone and the guy hooked up a tool to a plug under my dash and he showed it to me it said "coolant temperature sensor reading below normal temp range" he said i would need a new coolant temp sensor. but the more i read thee more it sounds like it might be the thermostat. The engine light went out as soon as he checked it and has not come back on yet but i will check out the thermostat first. thanks all
breeze is offline  
post #9 of 10 (permalink) Old 01-21-2010, 12:12 PM
Forum Regular
 
firigidice's Avatar
 
Join Date: Nov 2009
Location: Fort Worth Texas
Posts: 97
Garage
Quote:
Originally Posted by breeze View Post
i have a stupid question. do the cobalts actually display a code on thee dic ? this is the second time with my engine light. auto zone said the first time the cel came on it was cause fuel running too lean.i put fuel dry and injector cleaner in and fixed then a week ago it came on and never went out so they showed me the reading. but for these problems i have not seen a code come up. is this bad?
Your mistake is going to auto zone. Go to napa or orielly's
firigidice is offline  
post #10 of 10 (permalink) Old 01-21-2010, 01:56 PM
Forum God
 
hailcesar75's Avatar
 
Join Date: Nov 2008
Location: broooooklyn, NY
Posts: 2,969
How about pep boys? I ran over a big puddle on a heavy downpour and my check engine light came on. This happened last month. So u think pep boys is ok to check it?

Dropped Carbon Fiber SS, Project JDM

hailcesar75 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome