Wooow!!!!! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-10-2010, 11:42 AM Thread Starter
Forum Regular
 
SupaJenx's Avatar
 
Join Date: Sep 2009
Location: buffalo, new york
Posts: 104
Garage
Exclamation Wooow!!!!!

So I'm sitting in a parking lot, car running so I could have the heat on and I cycle through the info on my steering wheel and my coolant was at 208 degrees! It runs usually at like 190 cuz its bent wen I hit a curb. Should I look into replacing my radiator?
SupaJenx is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-10-2010, 11:44 AM
mmmm rice<3
YourCobalt.com Premium Member


 
Join Date: Jul 2009
Location: State College, PA
Posts: 837
Garage
were u runnin it hard before you were stopped

tylerh is offline  
post #3 of 7 (permalink) Old 02-10-2010, 11:44 AM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Thats normal if the car is just sitting idling. But if it is damaged...I would replace it.




XFE is offline  
post #4 of 7 (permalink) Old 02-10-2010, 11:58 AM
Cobalt Master
 
NitroheadZ28's Avatar
 
Join Date: Aug 2009
Location: Bk, NY- USA
Posts: 1,648
Garage
If you ran it, parked it and it was idling for a bit- then its normal for the temp to go higher as it idles.. But if you started it from cold, then then it should be at 170-180...

^^<==---___-A_m_e_r_i_c_a_n M_u_s_c_l_e-___---==>^^
NitroheadZ28 is offline  
post #5 of 7 (permalink) Old 02-10-2010, 12:15 PM
Cobalt Specialist
 
bchongarski's Avatar
 
Join Date: Jun 2009
Posts: 1,324
Garage
mine do taht too - no worries


GM STAGE 1 :
bchongarski is offline  
post #6 of 7 (permalink) Old 02-10-2010, 01:10 PM
Forum Regular
 
Join Date: Dec 2009
Location: se
Posts: 182
208 deg F is not bad, especially if, while observing the temp, it went down afterward. Its when it hits 230 you have to look into maybe fan problems, sensors, etc. I just went through that with another old car I have.......
pippo is offline  
post #7 of 7 (permalink) Old 02-11-2010, 08:05 AM
Forum Regular
 
ItzBlueBish's Avatar
 
Join Date: Aug 2009
Location: CA
Posts: 208
Low speed fan doesn't come on until 217* and shuts off at 190*. If you're at idle there's no air going through the radiator so it'll slowly creep to 217.
ItzBlueBish is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome