Wheel Cylinder Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-28-2011, 06:36 AM Thread Starter
Forum Regular
 
Join Date: Dec 2010
Posts: 51
Wheel Cylinder Help

Hey guys. I'm having a problem and need some advice. Any help is appreciated and thanks in advance. So here we go. I'm doing the brakes on my gf's 91' pontiac sunbird. The rear are drums and I'm replacing the wheel cylinders as well. I switched it out with the new one and bled the brakes. The pedal felt firm and I had my gf press on it one last time so I could watch it and make sure everything was moving right and one of the pistons and the rubber boot popped off of the new wheel cylinder. I've been all over the web trying to find out what could cause this to happen. The only things I could think of would be too much break fluid in the reservoir of just a faulty wheel cylinder. But I checked to other one I bought to see it was put together any better and they're both pretty much the same. Lost for a solution.
2.2BryGuy is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-29-2011, 02:14 PM
Forum Regular
 
noblite's Avatar
 
Join Date: Mar 2011
Location: Southern IL
Posts: 177
Where did you get the cylinder from and where was it made?
I had one made in China that just blew the piston out going down the road 3 days after I changed it.
noblite is offline  
post #3 of 7 (permalink) Old 03-29-2011, 09:22 PM Thread Starter
Forum Regular
 
Join Date: Dec 2010
Posts: 51
You blew the piston out while the drum was on? Someone told me that it was happening because the drum wasn't on when we pushed on the brakes. Yeah, it was without a doubt a DUH moment. Without the drum there to stop it, it came all the way out. In your case it sounds like the brakes weren't adjusted properly. The piston is meant to come out because the wheel cylinders are serviceable even though its recommended that you change them when your service your brakes. But I'm also not a pro by any means so don't take my word for it. Just a thought.

Last edited by 2.2BryGuy; 03-29-2011 at 09:25 PM.
2.2BryGuy is offline  
post #4 of 7 (permalink) Old 03-31-2011, 01:13 PM
Forum Regular
 
noblite's Avatar
 
Join Date: Mar 2011
Location: Southern IL
Posts: 177
I my case I just got a bad wheel cylinder when to another parts store got one made in the USA and it been fine ever since. I had replaced the cylinder with the brake shoes and everything was a installed corectly.
noblite is offline  
post #5 of 7 (permalink) Old 04-01-2011, 11:42 PM Thread Starter
Forum Regular
 
Join Date: Dec 2010
Posts: 51
Oh wow. I find if really crappy that they can get away with selling stuff that just plain doesn't work. Thats gunna keep me on my toes with this job I'm doing. Its my first major overhaul of a car but I'm excited to see how it goes. I've got both the new wheel cylinders in and new drums and shoes. Waiting on rotors for the front to come in so we can get it on the road and tested out. Not sure where the wheel cylinders were made but they were cheap (my girlfriend ordered them) But they are brand new if that means anything.
2.2BryGuy is offline  
post #6 of 7 (permalink) Old 04-02-2011, 01:18 AM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
tell me at least the shoes were installed while you did this "test". you should never do this without the drums installed. no one physically sees the wheel cylinders at work. if you did, you are at risk of over extending the pistons and this happening. sucks man...just put the piston back in and return it. say it was leaking when you installed it.

ff_drift_lol is offline  
post #7 of 7 (permalink) Old 04-02-2011, 01:30 PM Thread Starter
Forum Regular
 
Join Date: Dec 2010
Posts: 51
Yeah. The shoes were in. It did overextend but people have been telling me that its fine as long as all of the seals and the rubber boot are still good so I put it all back together and installed it. Made sure there was no dirt or anything like that on any of it. Gotta learn somehow right? Thats why I'm doing it on an $800 car. I'm pretty much teaching myself at this point with a haynes repair manual and the internet. I just put the otherside together today and was gunna have my gf help be bleed the brakes so i could take it around the block and test it out. If its not right then I'll try again. Like I said, it was a duh moment when I realized that the drum had to be on.
2.2BryGuy is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome