Power Locks Stopped Working - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-26-2013, 05:19 PM Thread Starter
Newcomer
 
Join Date: Sep 2013
Posts: 2
Power Locks Stopped Working

Rain got in my 06 cobalt and the locks started going crazy but they stopped going crazy but now they dont work. Power windows are all ok only thing wrong is the power locks on the passenger side and driver side. Any suggestions what it could be?

Last edited by Coby7; 09-26-2013 at 08:08 PM.
Lupita1005 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-26-2013, 08:09 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Power door lock fuse!!!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 8 (permalink) Old 10-03-2013, 03:39 PM
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
I got my interior steam cleaned and the detailer got ALOT of water in the switches

my locks started locking and unlocking continuously, then quit working all together

I tried everything, then finally changed the switches, all works now

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
post #4 of 8 (permalink) Old 10-03-2013, 08:17 PM
Super Moderator
 
swanman35's Avatar
 
Join Date: May 2013
Location: SWPA
Posts: 2,068
Yeah, rain got in mine. It was a down poor and A LOT of water got in it. It did the same thing, locking unlocking randomly. It was a problem cause i don't have my remote so the alarm went off when i opened my door. Just disconnected it for a while. Now it works fine

2005 cobalt base model coupe
swanman35 is offline  
post #5 of 8 (permalink) Old 11-08-2013, 05:39 PM Thread Starter
Newcomer
 
Join Date: Sep 2013
Posts: 2
Thank you all for your comments but I am going to try to change the switches is there anyway you guys can tell me how to switch them ? I would highly appreciate it.

---------- Post added at 07:39 PM ---------- Previous post was at 07:27 PM ----------

Quote:
Originally Posted by jignaczak View Post
I got my interior steam cleaned and the detailer got ALOT of water in the switches

my locks started locking and unlocking continuously, then quit working all together

I tried everything, then finally changed the switches, all works now
Is there anyway you can tell me how to change the switches ?
Lupita1005 is offline  
post #6 of 8 (permalink) Old 11-09-2013, 05:04 AM
Contributor
 
jignaczak's Avatar
 
Join Date: Dec 2011
Location: S.W. Pennsylvania
Posts: 455
Garage
It's very easy

Pull out the bezel that holds in all the switches by removing the screw in the handle pocket, and unplug all the switches

The lock switches push through the top, instead of through the bottom like all the other switches, so push I'm the little tab holding in the switch, then push on the back of the switch to push it through


Sent from AutoGuide.com App

John
2008 Cobalt LT
SS springs and Stagg struts
Pioneer AVIC-X930BT GPS
Memphis 16-MCH600 "Baby Belle" hybrid amplifier
MB quart Premium 6.5" componant/premium tweeters front
MB quart Premium 5.25 componant/premium tweeters rear
Memphis PR-10" sub in factory sub box

miles and miles of dynamat extreme...
jignaczak is offline  
post #7 of 8 (permalink) Old 11-09-2013, 05:56 AM
Super Moderator


 
Plain Jane's Avatar
 
Join Date: Mar 2013
Location: Montreal, Quebec
Posts: 3,860
Garage
I have a similar problem with my door locks. Rain got in through the window and corroded the contacts. I opened it up one day, pulled out the little chip board and scratched off the corrosion with a little pick, then 'painting in' the open circuit I had made with the pick with a metallic pen, slapped it all back together and it worked fine for a few weeks. When it let go again, I swapped it for the passenger side switch. Now only the lock side functions and not the unlock. Passenger side is a dud. I've learned to live with it now, it's not a bother anymore. Good luck.

'07 Eclipse GT build thread - 280whp, 254wtq
Plain Jane is offline  
post #8 of 8 (permalink) Old 11-27-2013, 11:08 AM
Initiate
 
Join Date: Nov 2013
Location: Near Monroe, Louisiana
Posts: 36
Garage
Good luck. I like my Mexican locks and windows. You know, - Man-u-al.
Louisiana is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome