2007 Cobalt LT, Should I ? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-18-2015, 08:24 AM Thread Starter
Newcomer
 
Join Date: Jul 2015
Posts: 2
2007 Cobalt LT, Should I ?

Hi, I am new here and just thought I would do a First post.
It’s important to me and would love to hear any comments.

I’m looking at a 2007 Cobalt LT and they want 3995.
It’s bright RED and not a scratch anywhere and I just Love it and just what I need.
It was 1 owner and has 100,081 miles on it.
It says All Re-Calls done on CarFacts !!

It’s a dealership and I went to give it a test drive and guess what ?
The engine light came on while testing the car.
I went back home and in a few hours the salesman called me and said “it’s off, we fixed it.
He said the fixed the front hood latch, (just needed some grease) and that the mechanic ran the car and got it up to 50-60 mph for a bit and the light went out and now it’s OK.

What do you think with this, should I take a chance.
I won’t hold you to it, ever, I just need some feedback.
Do Cobalts have these problems.?
I do realize there could be an underlying problem, of course, but any tips on how I might proceed could be of a great help.
TIA, jerry

Last edited by TABBYO; 07-18-2015 at 08:45 AM. Reason: added info
TABBYO is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-18-2015, 08:46 AM
Super Moderator


 
Plain Jane's Avatar
 
Join Date: Mar 2013
Location: Montreal, Quebec
Posts: 3,860
Garage
You got a CEL from a faulty hood latch? That doesn't sound right. How sketchy is this dealership you're dealing with?

'07 Eclipse GT build thread - 280whp, 254wtq
Plain Jane is offline  
post #3 of 4 (permalink) Old 07-18-2015, 11:13 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Wait now, if it has remote start this could happen. If it doesn't have remote start somebody is lying to you.

---------- Post added at 03:13 PM ---------- Previous post was at 03:13 PM ----------

I would also check if it has the revised timing chain tensioner.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 07-18-2015 at 07:15 PM.
Coby7 is offline  
post #4 of 4 (permalink) Old 07-18-2015, 06:04 PM Thread Starter
Newcomer
 
Join Date: Jul 2015
Posts: 2
Hi, thanks for your interest in my post.
I didn’t mean to emphasize that the hood latch could have caused a CEL but just thought I would mention it with as little additional info as I have with the situation.

I am really very un-informed about Cobalts, so far, and just fishing for ideas before I invest $$.
Thanks for mentioning the “timing chain tensioner” issue.
That’ll be a good question I can ask.

Actually, I have decided to bring a mechanic friend along to check it out next week.
I will let you know if I find out anything else.

Thanks folks.
TABBYO is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome