Only 3rd Gear, No Spedometer - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-09-2016, 07:39 PM Thread Starter
Prospect
 
Join Date: Dec 2015
Posts: 12
Only 3rd Gear, No Spedometer

Immediately after changing the starter (probably not related) when I started the car the security light was lit, POWER STEERING came on and the engine light.
I finally drove it. Security light is off but it's stuck in 3rd gear and the speedometer doesn't work. Last week when I let it run, the tach didn't work either.
The only code is for the speedometer not working which is obvious. This seems to be a common issue maybe the transmission control module is shot, or it's the ground wire that needs to be wire brushed. Does anyone have any suggestions or the whereabouts of the TCM ground wire.

I spent a lot of time fixing issues that shouldn't have worn out and my mother can't drive it still. Very frustrating!!

Edit-
The car sat for a good month when the starter died until I could fix it. I don't think a ground wire could have gone bad unless it's an upsetting coincidence. Maybe it's a sensor or fuse? I don't see any bad fuses and I swapped relays around though.
TIA

Last edited by Rochev; 01-09-2016 at 08:06 PM.
Rochev is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-13-2016, 02:44 PM Thread Starter
Prospect
 
Join Date: Dec 2015
Posts: 12
Does anyone know where the TCM and BCM ground wires lead to so I can clean them off?
Rochev is offline  
post #3 of 5 (permalink) Old 01-13-2016, 06:01 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
BCM ground is under the driver's seat and TCM is on the radiator support. You may want to remove and re-insert the blue connectors on the BCM to clean the contacts a bit too.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #4 of 5 (permalink) Old 01-15-2016, 03:35 PM Thread Starter
Prospect
 
Join Date: Dec 2015
Posts: 12
Quote:
Originally Posted by Coby7 View Post
BCM ground is under the driver's seat and TCM is on the radiator support. You may want to remove and re-insert the blue connectors on the BCM to clean the contacts a bit too.
I'll give that a shot, thank you
Rochev is offline  
post #5 of 5 (permalink) Old 01-17-2016, 12:52 PM Thread Starter
Prospect
 
Join Date: Dec 2015
Posts: 12
I ran a new ground to the hole in the TCM to the fender bolt and all is fixed! I hope its a permanent fix
Rochev is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome