Cobalt 2006 SL Headlights Do Not Work - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-28-2016, 09:59 AM Thread Starter
Newcomer
 
Join Date: Sep 2016
Posts: 2
Cobalt 2006 SL Headlights Do Not Work

A few days ago my Cobalt '06 SL Headlights were working. Now, both Headlights ( low and high beam) do not work. However, the running lights are fine. Any suggestions would be appreciated.
davedrew is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-28-2016, 10:37 AM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
What are SL headlights? Or did you mean that the car is an LS trim, and they're stock headlights?

I'd probably suggest checking bulbs first. Make sure they're not burnt out.


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
post #3 of 6 (permalink) Old 09-28-2016, 01:00 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Well the 06 uses the blinker filaments for DRLs and has a separate ground than the headlamps. You can check each filament separately if you have help or if you can park up against a building.

https://www.yourcobalt.com/forums/ele...-headlamp.html

If they test out okay then you'll have to look at your light switch.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #4 of 6 (permalink) Old 09-28-2016, 04:59 PM Thread Starter
Newcomer
 
Join Date: Sep 2016
Posts: 2
They are the standard stock headlights on my Cobalt '06. The left side front headlamp was replaced a few weeks ago, so the bulb is new. But both headlights will not come on, and they were working up until yesterday. I was thinking maybe a fuze problem.
davedrew is offline  
post #5 of 6 (permalink) Old 09-28-2016, 05:37 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Si your thinking is new must be good! Beware!!!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #6 of 6 (permalink) Old 11-01-2016, 07:17 PM
hawaii icon
Staff Alumni
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
agita_san's Avatar
 
Join Date: Feb 2010
Location: Makakilo, Hawaii
Posts: 3,089
Garage
Both my lights stopped working too. For me it was that plug that connects the headlight harness to the car. Some water got in and the pins rusted out. Replaced both plugs (on the car side) and new headlight harnesses and everything is golden now.

Aspire to Inspire the Aspirations of the Inspirational
www.facebook.com/islandecotecs
agita_san is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
cobalt '06 , headlights , running lights ok.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome