05 Cobalt Help! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-28-2008, 11:00 PM Thread Starter
Newcomer
 
Join Date: May 2008
Posts: 1
Angry 05 Cobalt Help!

Hello everyone, I am new to this place, so hello! But I have some questions about my 05 Cobalt. I just bought it around two weeks ago. I have a 4 door LS Copper Cobalt. I love my car so far! But I have been having some problems, and wanting to see if anyone can help me. First of all the same day I drove it off the lot, my check engine light came on. Well I took it to AutoZone to see what was wrong, they told me it was a Catalytic converter. Well I took it back to the dealership, and they sent it to a local Chevy dealership to get it replaced. Well I got it back, and the light was off for the rest of the day. Next day I was driving around, and it came back on. Now I dont know whats going on? Also, my car seems to be eatting gas like crazy! Whats up with that? It takes it about a two days to get down to a half tank? Anyone else have this problem? Please help me if you can! Thanks so much!
TheWickedOne87 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-29-2008, 12:00 AM
Forum Regular
 
RacingSolution's Avatar
 
Join Date: Jul 2006
Posts: 115
Send a message via AIM to RacingSolution
Sounds like the two are going hand in hand.. Your car is running rich for some odd reason and its eating gas and burning up your catalytic converter.. Take it back to the dealership and cause a fuss
RacingSolution is offline  
post #3 of 7 (permalink) Old 05-29-2008, 12:30 AM
Cobalt Master
 
cobaltkrazy's Avatar
 
Join Date: Nov 2006
Posts: 1,538
I second, something like that is cause for concern. Take it back, and request another. If they dont give it to ya, cause a stink.

Cobaltkrazy: Turning aftermarket parts to dust, since 2006!!!

Quote:
Originally Posted by BlakdOut07LT View Post
ill be the DRUNKEST mofo there btw can someone keep an eye on my kid while i go get another beer?
How to post pics:
https://www.yourcobalt.com/forums/ins...tml#post169806
cobaltkrazy is offline  
post #4 of 7 (permalink) Old 06-05-2008, 10:16 AM
Forum Regular
 
Hogger's Avatar
 
Join Date: Nov 2007
Location: Kennewick, WA.
Posts: 75
I need to take mine in for the same thing. But my light goes off after a couple weeks.... Makes me feel better, but I know, I still need to get it fixed before it turns into something worse.
Although my mileage doesn't seem to be hurt.

Minor mods... Wheels, de-badged & de-trimmed, stereo, grill, intake, eyelids.
Hogger is offline  
post #5 of 7 (permalink) Old 06-05-2008, 01:57 PM
Forum Regular
 
arrival05cobalt's Avatar
 
Join Date: May 2008
Posts: 51
i had the same problem with my 05. i plugged it in to the scanner at work and it was reading 2 codes about my injectors ... try running a bottle of sea foam through a half a tank of premuim..

worked for me

Marcus
(Fast Inc)
arrival05cobalt is offline  
post #6 of 7 (permalink) Old 06-05-2008, 06:32 PM
Prospect
 
Join Date: Dec 2007
Posts: 14
Buddy of mine owns a SS (I've got a lowly LS). Anyway, his car (a stick) was running at high idle with a check engine light. First they told him it was the injectors. After searching around, they determined that a vacuum line running in the center console has worn through because of contact with the shafts connecting the gear shifter to the transmission. Replaced the vacuum line and POOF, problem solved.
chief_bs is offline  
post #7 of 7 (permalink) Old 06-06-2008, 10:03 PM
Veteran
 
Join Date: Dec 2004
Posts: 703
could be the oxygen sensor
steve333 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome