RPM problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Chevy Cobalt Owners Lounge General Chevy Cobalt discussion

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 01-15-2009, 07:21 AM Thread Starter
Newcomer
 
Join Date: Jan 2009
Posts: 3
Unhappy RPM problem

Hey guys and gals, Having a problem with my 06 cobalt. The rpm redlines at 4000? it wont go any higher. I'm not sure what would cause this, Any help would be great
snoman186 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 01-15-2009, 07:36 AM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
Could you be a little more specific? Are you trying to rev more more than 4000 RPMs in neutral? If so, the ECM is going to keep you from over revving the engine...designed that way

Ex-Cobalt Owner
Red07SSNA is offline  
post #3 of 12 (permalink) Old 01-15-2009, 07:52 AM
 
Join Date: Oct 2008
Posts: 292
^ditto, put the car in drive then punch it and it'll go past 4k i bet.
knoxbox is offline  
post #4 of 12 (permalink) Old 01-15-2009, 08:21 AM Thread Starter
Newcomer
 
Join Date: Jan 2009
Posts: 3
I figured that, even in drive it's the same problem... ???
snoman186 is offline  
post #5 of 12 (permalink) Old 01-15-2009, 08:22 AM
 
Join Date: Oct 2008
Posts: 292
your having the same problem in drive? take it to the dealership.
knoxbox is offline  
post #6 of 12 (permalink) Old 01-15-2009, 09:13 AM Thread Starter
Newcomer
 
Join Date: Jan 2009
Posts: 3
Yeah, I just was hoping to have a idea of what it could be before I go. Thanks for your help...
snoman186 is offline  
post #7 of 12 (permalink) Old 01-15-2009, 09:41 AM
 
Join Date: Oct 2008
Posts: 292
i have no idea, 4000 rpm is normal for neutral and park, but not drive.. weird.. sounds like a ecu issue maybe...
knoxbox is offline  
post #8 of 12 (permalink) Old 01-15-2009, 09:48 AM


 
Join Date: Apr 2008
Posts: 1,559
Garage
I got mine to redline in neutral just look at my tach in my sig
Powered By LE5 is offline  
post #9 of 12 (permalink) Old 01-15-2009, 09:54 AM
 
Join Date: Oct 2008
Posts: 292
there is no tac in your sig lol and the cluster is so small in your sig you can't tell if its redlined anyways, but the ecu keeps it from redlining in neutral or park, can only be fixed with a tune so unless your tuned its just a flo0k or you thought you were in neutral and wasn't. lol. btw we are talking about automatics here not 5speed not sure which you have. 5 speed you can redline in neutral yes.
knoxbox is offline  
post #10 of 12 (permalink) Old 01-15-2009, 03:41 PM
Contributor
 
Join Date: Oct 2008
Posts: 324
Zero to 60 in 8 secs whooooo hooooooooh lol just cuz
shanksbaby is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome