Turn Signal Issue - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Electrical Electrical DIY/How-to's

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-24-2015, 09:12 PM Thread Starter
Newcomer
 
Join Date: Dec 2013
Location: Haltom City, TX
Posts: 6
Turn Signal Issue

I just replaced my stock headlights with CCFL Halos and LEDs, and I figured out how to wire everything up pretty easily.

But what's really frustrating is that while the turn signal seems to work fine on one side (amber bulb is on, but flashes brighter when engaging the turn signal switch), on the other side the bulb only comes on when the turn signal switch is engaged.

I swapped out the two bulbs (both brand new), and I still get the same result. I tried two other brand new bulbs, and I got the exact same result.

I thought it might be a problem with the parking lights wire, but that's the wire I tapped into for the Halos and LEDs, and they are working fine.

The only thing I can think of now is that it has to be some kind of problem with that particular bulb socket. Does anybody know if it's possible to order and replace just the bulb socket, or the wiring harness that includes all the bulb sockets?

Any other ideas as to what might be wrong here?

Thanks for your help!
ddoyle76 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome