Need Some Help...guiz - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Engine Mods Talk about Chevy Cobalt Engine Modifications here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-01-2010, 01:30 PM Thread Starter
Expert


 
golfin's Avatar
 
Join Date: Jul 2009
Location: Abbotsford, British Columbia
Posts: 992
Garage
Send a message via Skype™ to golfin
Need Some Help...guiz

I'm going to try my best to make this short and sweet.

I was driving around last Sunday. Go to start my car and it starts to misfire like crazy. My check engine starts flashing and my AFR gauge goes to 16.8 and doesnt leave it. I manage to wrangle my car down the hill to my house, park and leave it. Go to start it 4 hours later. PERFECTLY FINE. Drive it until today with no problems what soever. Driving around today and bam AFR goes to 17 and it starts misfiring like a champ again. I get it home check my codes and im throwing the P0300-Engine misfire which was quite obvious, but also a whatever code which is INJECTOR #3 something or other.

My question is did my injector just go bad? can it go bad? I had to go to work. when i get home ill pull apart the injectors and such. but what should i look for? its annoying. i just want to get rid of my balt

golfin is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-01-2010, 01:42 PM
YourCobalt.com Premium Member


 
finnscobalt's Avatar
 
Join Date: Mar 2009
Location: Lower Alabama
Posts: 2,473
Send a message via Yahoo to finnscobalt
Yes, injectors can and do go bad. It could be just clogged or totally fried. Anything electonic can go bad, sometimes on a whim.



sig pic courtesy of GBALT05
finnscobalt is offline  
post #3 of 6 (permalink) Old 07-02-2010, 11:00 AM Thread Starter
Expert


 
golfin's Avatar
 
Join Date: Jul 2009
Location: Abbotsford, British Columbia
Posts: 992
Garage
Send a message via Skype™ to golfin
update. get up this morning start the car let it run 5 minutes perfectly fine. drive it 5 minutes perfectly fine. go to start it two hours later. Service traction comes on and it starts misfiring again.

Ideas guys...shits facked and im pulling 18 hour days right now with no car. i dont have time to rip the whole car apart

golfin is offline  
 
post #4 of 6 (permalink) Old 07-02-2010, 11:05 AM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
wow thats weird. ummm does the afr go lean only at idle? or while cruising too? if while cruising, do you feel power loss? is it abrupt, does it sputter, explain what happens best you can.

ff_drift_lol is offline  
post #5 of 6 (permalink) Old 07-02-2010, 09:46 PM Thread Starter
Expert


 
golfin's Avatar
 
Join Date: Jul 2009
Location: Abbotsford, British Columbia
Posts: 992
Garage
Send a message via Skype™ to golfin
im not driving it, because honestly its un driveable. but yeah when i tried it did it while driving and idling. all the time. the code is p0203 injector 3 control circuit....

and its knocking the engine and its making the whole car shake basically. it gets worse when i put it in gear too? im in the process of taking out the injectors...cleaning and checking and then i dont know what to do

---------- Post added at 09:46 PM ---------- Previous post was at 08:28 PM ----------

sooo uhhhhhhh, yeah the third injector wasnt plugged in all of the sudden...........so im assuming at this moment that was the problem. but now injector one is leaking because the seal broke so i need #42 injectors asap

golfin is offline  
post #6 of 6 (permalink) Old 07-02-2010, 09:49 PM
I cut stuff
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
blazerlow's Avatar
 
Join Date: Aug 2009
Location: MN
Posts: 6,238
Garage
blazerlow is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome