Coolant Reading _ _ _F FAN RUNS ON HIGH! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Engine Mods Talk about Chevy Cobalt Engine Modifications here.

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 06-09-2013, 04:58 AM Thread Starter
Forum Regular
 
kevin_911's Avatar
 
Join Date: Jun 2012
Posts: 72
Exclamation Coolant Reading _ _ _F FAN RUNS ON HIGH!

My 2008 Cobalt 2.2 cooling fan is running on high speeds and won't shut off until I turn the car off. The coolant say it's _ _ _ F. Anyone have this problem before. If So can you help me out on How to fix it. By the way no Cell and yes the thermostat is open hot fluid in the hose.

2008 Chevy Cobalt LT 2.2!
kevin_911 is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 06-09-2013, 05:30 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Bad connection to coolant temperature sensor or bad sensor.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 26 (permalink) Old 06-09-2013, 05:37 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Quote:
Originally Posted by Coby7 View Post
Bad connection to coolant temperature sensor or bad sensor.
This. Its usually just a bad connection though

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
 
post #4 of 26 (permalink) Old 06-09-2013, 01:32 PM Thread Starter
Forum Regular
 
kevin_911's Avatar
 
Join Date: Jun 2012
Posts: 72
I checked the connection but no fix. So I'm going to try and replace it. Thanks for everyone's help.

2008 Chevy Cobalt LT 2.2!
kevin_911 is offline  
post #5 of 26 (permalink) Old 06-09-2013, 01:50 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Delete the code and see if your temp comes back first. If it does, its a bad connection

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #6 of 26 (permalink) Old 06-09-2013, 01:58 PM
Contributor
 
Join Date: Dec 2012
Posts: 428
Garage
mine did the same thing and the connection was just bad the plug was dirty so it was locked together
derekhollister is offline  
post #7 of 26 (permalink) Old 06-14-2013, 02:33 AM Thread Starter
Forum Regular
 
kevin_911's Avatar
 
Join Date: Jun 2012
Posts: 72
I replaced the sensor and it was working all day. Until I headed home from work and it's saying COOLANT ---F again. Connection is good,wires to plug is good. Is there a chance it could be the thermostat?

2008 Chevy Cobalt LT 2.2!
kevin_911 is offline  
post #8 of 26 (permalink) Old 06-14-2013, 05:04 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Nope!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #9 of 26 (permalink) Old 06-14-2013, 10:24 AM Thread Starter
Forum Regular
 
kevin_911's Avatar
 
Join Date: Jun 2012
Posts: 72
How would I go about fixing this?

2008 Chevy Cobalt LT 2.2!
kevin_911 is offline  
post #10 of 26 (permalink) Old 06-14-2013, 11:37 AM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
Follow the wires from the temp sensor to make sure it is not getting grounded somewhere it shouldn't be

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome