CEL Trouble - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Engine Mods Talk about Chevy Cobalt Engine Modifications here.

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 11-11-2008, 12:57 PM Thread Starter
Newcomer
 
fast=lane's Avatar
 
Join Date: Jun 2007
Location: Ursa, Il.
Posts: 28
CEL Trouble

Does anyone know why i would be throwing a CEL that says low coolant temperature? My coolant levels are all topped off but my cel keeps coming on?
fast=lane is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-11-2008, 01:43 PM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
It's a warning that your coolant isn't getting hot, not the level of the coolant is low. What does your DIC show the engine temprature is when this message comes on? Could be your thermostat is stuck open.

Ex-Cobalt Owner
Red07SSNA is offline  
post #3 of 11 (permalink) Old 11-11-2008, 03:01 PM
OBZ
Staff AlumniDedicated


 
OBZ's Avatar
 
Join Date: May 2006
Location: S.L.C. UT.
Posts: 3,006
^^ thats my guess also..



"A wise man speaks because he has something to say,
A fool speaks because he has to say something"
OBZ's showoff thread!
OBZ is offline  
 
post #4 of 11 (permalink) Old 11-11-2008, 03:42 PM
Forum Regular
 
CobaltDude06's Avatar
 
Join Date: Sep 2007
Posts: 73
i have the same code it comes and goes so its either thermestat stuck open or a bad sensor i think its a sensor on mine and i cant take it in i have no warrenty im gonna fix it during thanksgiving when i have free time

2006 Cobalt LT
Black X-Ray Edition
New straight through design muffler
Ebay Cold Air Intake
Front Badge Brushed Alum Bowtie w/ Autobot Transformer
Billet Grille
Tinted Tail Lights
Tinted Side Markers
Tinted Reverse Lights
Rear and Side Emblem Debadge
Strut Bar
Eyelids
CobaltDude06 is offline  
post #5 of 11 (permalink) Old 11-12-2008, 01:07 PM
Cobalt Specialist
 
B-Low187's Avatar
 
Join Date: Jan 2006
Location: FL
Posts: 1,119
i have the same light and i have had it removed like 5 times and it keeps coming back. sometimes it wont come back for a few days and other times in just minutes. i had no idea what the hell was wrong either. its been on for like 6 months now probably. it hasnt hurt anything but i would like to get it fixed
B-Low187 is offline  
post #6 of 11 (permalink) Old 11-12-2008, 04:01 PM
Cobalt Specialist
 
B-Low187's Avatar
 
Join Date: Jan 2006
Location: FL
Posts: 1,119
if its a sensor and not just the thermostat stuck open, what sensor would it likely be?
B-Low187 is offline  
post #7 of 11 (permalink) Old 11-12-2008, 04:36 PM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
Engine Coolant Temperature (ECT) Sensor located on the upper cylinder block -- on the upper right rear corner of the cylinder block -- corner closest to the driver.

What is the DTC code you get? P0??? Also, what does the DIC show your coolant temperature is when you see the message?

Ex-Cobalt Owner

Last edited by Red07SSNA; 11-12-2008 at 04:49 PM.
Red07SSNA is offline  
post #8 of 11 (permalink) Old 11-12-2008, 04:41 PM
Cobalt Specialist
 
B-Low187's Avatar
 
Join Date: Jan 2006
Location: FL
Posts: 1,119
i havent had mine scanned in awhile because it just keeps coming back after they delete it so im not exactly sure. and my car is in the body shop getting somw custom work done so i cant go get the code scanned

i just remember that the guys always told me it was for low coolant or something with the coolant system. the first thing i checked were my fluid levels but they were all fine.

maybe somebody else that has this problem can go get it scanned and write down the code??
B-Low187 is offline  
post #9 of 11 (permalink) Old 11-14-2008, 11:43 AM
Newcomer
 
icarus4586's Avatar
 
Join Date: Jul 2006
Location: Rochester, NY
Posts: 11
Press the "i" button behind the steering wheel to cycle through until coolant temperature is displayed. Report back what it says. This will really help diagnose whether it's the sensor or the thermostat.

2005 Cobalt Sedan - Injen Intake & Magnaflow Exhaust
icarus4586 is offline  
post #10 of 11 (permalink) Old 11-18-2008, 01:22 PM Thread Starter
Newcomer
 
fast=lane's Avatar
 
Join Date: Jun 2007
Location: Ursa, Il.
Posts: 28
It usually reads 206 degrees. Im going to the dealership 2day and il c what they say
fast=lane is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome