starting issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Engine Mods Talk about Chevy Cobalt Engine Modifications here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-14-2009, 12:57 PM Thread Starter
Newcomer
 
Join Date: Jan 2009
Posts: 1
starting issues

I have a 05 Cobalt with 108,000 miles on it, and it seems to have a problem starting. The fuel filter has never been replaced, and it was really, REAlly low on oil when the engine shut down. Now I, as her boyfriend suggested a clogged fuel filter as the cause of the problem. Is there any other suggestions anyone can think of?
lclayton2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-14-2009, 06:24 PM
Forum Regular
 
Iron Ranger's Avatar
 
Join Date: Nov 2008
Posts: 117
Yeah, I think the time's right for a fuel filter change. May also want to check the spark plugs for excessive wear.

Hopefully, with low oil in the vehicle, nothing internal was damaged.

Was the car taking awhile to start or would it run really rough when it was idling?

Hopefully, the fuel pump is still operational. 108,000 miles is still relatively new, but odd things do happen.............

No codes thrown?
Iron Ranger is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome