Engine Temp Indication Quits - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Forum FAQ's and How-to's (READ FIRST) This is a forum for all members to use when they have questions about anything on the forum.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-30-2016, 01:21 PM Thread Starter
Newcomer
 
Join Date: Apr 2015
Posts: 4
Engine Temp Indication Quits

I have a 2008 Cobalt and the engine temp keeps going to ____ and the engine light comes on. I remove the Engine Module plug and clean it and mess around with the other plugs in that area and the light goes out and temp display returns. This morning the temp quit at about 69 degrees C. The temp was hovering there?????

Last edited by Snowbusman; 01-30-2016 at 01:22 PM. Reason: Spelling
Snowbusman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-30-2016, 03:28 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,819
Garage
Try cleaning the connector on the coolant temperature sensor or replace it altogether.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome