Paint Problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Interior & Exterior Styling Talk about Chevy Cobalt interior and exterior products such as body kits, spoilers, steering wheels, shift knobs, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-28-2013, 04:39 PM Thread Starter
Newcomer
 
Project Alice's Avatar
 
Join Date: Jul 2011
Posts: 6
Paint Problem

I just finished painting my interior trim panels for the second time. They are painted with duplicolor Chrome, however every time i try to use a clear coat sealant (I have tried Duplicolor color match clear & Rustoleum clear coat sealant) it turns the chrome from shiny and chrome-like to a really ugly off grey/silver color. The first time I painted them was when I noticed it, which is why I had to repaint them. The first time I let them sit for about an hour before putting the sealant on. Then re-sanded and repainted, waited overnight and then put sealant on and the same thing happened. Ugly silver color. So I re-sanded and painted everything the second time. The paint has been sitting for about 3 days now and is still flaky and rubs a bit when I touched it. I really think it needs a clear coat/sealant to withstand being back in the car, any Ideas on what could fix this problem???
Project Alice is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-28-2013, 04:43 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
hmm, what grit sandpaper are you using? what about using a varnish?

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
post #3 of 4 (permalink) Old 07-28-2013, 05:18 PM Thread Starter
Newcomer
 
Project Alice's Avatar
 
Join Date: Jul 2011
Posts: 6
I used 1000 grit dry sandpaper each time
Project Alice is offline  
 
post #4 of 4 (permalink) Old 07-28-2013, 05:30 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
weird that its not sticking. Maybe try an adhesion promoter which im pretty sure duplicolor makes.

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome