Hello! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
New Member Introductions For new members of YourCobalt.com to introduce themselves!

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 06-02-2010, 03:47 PM Thread Starter
Newcomer
 
Join Date: Jun 2010
Location: Littleton, CO
Posts: 7
Hello!

Just wanted to say hello, as I am new to the Cobalt world. I just picked up an 06 SS/SC, blk on blk last week, and am LOVING IT. To be completely honest this is my first sporty car, I've owned nothing but Jeeps my entire life.

Any who, I've got a question and hoping you guys can help me out with it.

First off, it appears that the previous owner had either a axle back magnaflow exhaust installed or just the tip and resonator, installed (sorry not horribly mechanically inclined here so just going off a guess). It appears that whoever installed it either did not know what they were doing or decided they could do their own welding for the exhaust hanger.

Basically the last OEM hanger did not line up with the resonator, so they decided to weld their own hanger further back directly on the resonator... this is causing a horrible sounding squeak (metal rubbing on metal) whenever the car is idling. I took some pictures today but forgot my SD card reader so I will have to post those when I get home.

Has anyone here ever seen this done? what do you guys thing the best plan of action is to fix the issue? any ideas and suggestions are greatly appreciated.

Again I will post pics as soon as I get home.

EDIT: pics posted, Thanks!

Last edited by TiE2000; 06-02-2010 at 04:58 PM.
TiE2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 06-02-2010, 03:50 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Welcome to the forum!


Post pics of the issue and then I'll go from there on a possible resolution.




XFE is offline  
post #3 of 16 (permalink) Old 06-02-2010, 04:09 PM
Forum God


 
09-Cobalt-lt's Avatar
 
Join Date: Aug 2009
Location: North Vancouver, B.C.
Posts: 2,625
Welcome!

Im assuming you're talking about the muffler not the resonator, but it shouldn't make a noise unless the weld broke... definately be easier with a pic
09-Cobalt-lt is offline  
 
post #4 of 16 (permalink) Old 06-02-2010, 04:15 PM
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
LSlowBalt's Avatar
 
Join Date: Aug 2009
Location: Roaring Springs, PA
Posts: 1,429
Garage
Send a message via Yahoo to LSlowBalt
LSlowBalt is offline  
post #5 of 16 (permalink) Old 06-02-2010, 04:57 PM Thread Starter
Newcomer
 
Join Date: Jun 2010
Location: Littleton, CO
Posts: 7
TiE2000 is offline  
post #6 of 16 (permalink) Old 06-02-2010, 05:42 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
It looks like that it's just welded at a bad angle. Im sure you can take it to a shop and have them just redo it.




XFE is offline  
post #7 of 16 (permalink) Old 06-02-2010, 05:51 PM Thread Starter
Newcomer
 
Join Date: Jun 2010
Location: Littleton, CO
Posts: 7
Quote:
Originally Posted by XFE View Post
It looks like that it's just welded at a bad angle. Im sure you can take it to a shop and have them just redo it.
should I make sure they utalize all the hangers? As you can see in the last pic they completley skipped the hanger off to the right of the muffler. Would it not make sence to have some sort of harness going from one hanger to the other, or are all the hangers supost to be welded to the muffler?

sorry again I am not the most macanically inclined person in the world.
TiE2000 is offline  
post #8 of 16 (permalink) Old 06-02-2010, 05:53 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Quote:
Originally Posted by TiE2000 View Post
should I make sure they utalize all the hangers? As you can see in the last pic they completley skipped the hanger off to the right of the muffler. Would it not make sence to have some sort of harness going from one hanger to the other, or are all the hangers supost to be welded to the muffler?

sorry again I am not the most macanically inclined person in the world.
Ya, your best bet is to just take it to a shop and have them throw it up on the lift and they should be able to tell from looking at it that it is not right. It looks like it's hanging weird.




XFE is offline  
post #9 of 16 (permalink) Old 06-02-2010, 06:00 PM Thread Starter
Newcomer
 
Join Date: Jun 2010
Location: Littleton, CO
Posts: 7
Quote:
Originally Posted by XFE View Post
Ya, your best bet is to just take it to a shop and have them throw it up on the lift and they should be able to tell from looking at it that it is not right. It looks like it's hanging weird.
Thanks, I was planning on doing that this friday (payday) I'll post updates then.
TiE2000 is offline  
post #10 of 16 (permalink) Old 06-02-2010, 07:01 PM
Expert


 
Miss_Cobaltous2's Avatar
 
Join Date: Oct 2009
Location: Virginia
Posts: 757
Garage
Send a message via Skype™ to Miss_Cobaltous2
welcome to YC!!
Miss_Cobaltous2 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome