Can't Get All the Emission Parameters to Activate on 09 2.2 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-28-2018, 10:22 AM Thread Starter
Prospect
 
Join Date: May 2015
Posts: 27
Can't Get All the Emission Parameters to Activate on 09 2.2

This issue is getting to me... I have to pass an OBD emissions type test in 2 months. I have a decent scanner that shows no CODES no PENDING codes but the emission status is reading not ready. Unlike other jurisdictions here ALL systems must read ready to pass now.

The car had a P0104 code 2 months ago, which I got rid of by cleaning the throttle body and MAF sensor. I also changed the air filter and CLOSED a gap the pinhead at the oil change place left in the air intake box because it was so hard to close properly. (then leave alone like I told you clowns on the work order LOL)

Since then I have had no codes. Much better documented gas mileage and overall performance IMO.

However my reader continues to state the evap system is not ready to emission test... I read that if you constantly have a full tank of gas it won't activate, of which I was guilty. I never let the tank go below 3/4's in the colder weather as I don't drive much then and would fill up every week out of habit.

After reading that could be the problem I left the gas tank between 3/4's of a tank but never below 1/4 as verified by the reader too, for the last 135 miles. After almost 2 weeks of regular driving I still can't get a code to point where to look or a ready to test signal.

Any thoughts on how to tackle this issue, cheaply without just throwing parts at it?
Canuck2fan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-28-2018, 12:16 PM
Contributor
 
Join Date: Jul 2016
Posts: 452
Evap is the last to set. There are only a few specific times the evap system will conduct a test.
Once all other conditions are set Then I’d the conditions are met will the evap monitor test run.
Going on memory only.
All other monitors are ready.
From cold start and fuel at 3/8-3/4
Run at steady speed ....can’t remember If 50-55mph steady for 5 mi.

BC

Last edited by 1966tbird; 05-28-2018 at 12:21 PM.
1966tbird is offline  
post #3 of 6 (permalink) Old 05-28-2018, 02:14 PM Thread Starter
Prospect
 
Join Date: May 2015
Posts: 27
Thanks for the reply will try a cold start fun at 55 MPH once everything else is activated. It was so much easier when you could get a conditional pass with one system not ready but no trouble codes LOL.
Canuck2fan is offline  
 
post #4 of 6 (permalink) Old 06-01-2018, 05:06 PM
Newcomer
 
Join Date: Jun 2014
Posts: 1
Question Can't Get All the Emission Parameters to Activate on 09 2.2

Hang in there Just went through this last week with an 06 had a bad secondary air control valve - replaced valve - cleared codes - after a couple of days all tests were complete except the evaporative emission test - kept fuel between 3/4 and 1/4 eventually it finished the test 264 Miles - 20 starts and 10 days
I did read you have to run the AC and turn on the rear window defogger - didn't put any stock into it - but I was almost out of month to get a sticker so I tried it - and don't want to lead anyone astray - but the day it finally completed the test I drove it to work with the AC and rear window defogger on - obviously YMMV - Good luck would like to hear back
jforce is offline  
post #5 of 6 (permalink) Old 06-01-2018, 08:22 PM
Contributor
 
Join Date: Jul 2016
Posts: 452
I got to try that AC & defogger. @jforce , where did you find that little pearl of wisdom?

BC
1966tbird is offline  
post #6 of 6 (permalink) Old 06-03-2018, 02:41 PM Thread Starter
Prospect
 
Join Date: May 2015
Posts: 27
I just gave the ac and defrost a try... No luck yet but I have only done just over 200 miles since I reset the last time. Still no codes or pending codes. Will drive it some more tomorrow and see what happens.
Canuck2fan is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome