Alternator or Battery? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-16-2018, 01:53 PM Thread Starter
Newcomer
 
Join Date: Jun 2012
Location: TX
Posts: 8
Alternator or Battery?

Hi all,

2008 4 door LS, ~108k miles. Recently had AC cooling fan assembly replaced in May.

So my issue, I started the car this morning and had no issue. After getting some coffee getting back in the car to head home I noticed that when I turned the car on the AC wasn't blowing cold as it was previously (although was still blowing air) and the battery light was on. Hadn't seen that issue pop up before to my knowledge but I thought it might be the battery since its been about 6 years since its been replaced.

Went to wally world, the guy there said its the alternator and that if they put in a new battery it would kill the alternator. So, drove home, and noticed that other things were starting to go out. First radio cut out, then power steering, then it all went downhill. Saw dash messages for power steering and air bags pop up, and then my gauges wouln't work. Was still able to drive the car a bit and when I got up to speed, the gauges would register it, but other than that it I could tell it was about to die. Almost got home, everything started to turn off,
couldn't get past 20-30 mph or so, and then finally no response when I hit the
gas and it rolled to its resting place. Turned it off, waited a bit, then turned it
back on (or tried to) and it just clicked a bit. Could tell it was trying to start but that was about it. Couldn't even put it in neutral to push it back to my apts (it died literally a street away from my place).

Called a tow truck, and had it towed to a mechanic I use for oil changes which is relatively close to me. My preferred mechanic is a bit further away or else I'd have towed it to him.

I figure its the alternator based on quick searches on here and from what the Wally world guy told me, but figured I'd ask here just in case before I call the mechanic shop and tell them whats up. Either way, I know this is gonna cost a pretty penny.

So yeah, is it the alternator or battery? Or something else completely? Any chance its related to the fan assembly I had repaired a few months back?

Thanks ahead of time!
guitarguy_82 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-17-2018, 04:42 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Could also be the alternator wiring, but definitely alternator issue. Let's hope you didn't kill the battery in the process.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 6 (permalink) Old 09-17-2018, 06:46 AM Thread Starter
Newcomer
 
Join Date: Jun 2012
Location: TX
Posts: 8
Thanks, Coby. Shop called me this morning and said its the serpintine belt that was the issue. They are going to replace that and check against the alternator.
guitarguy_82 is offline  
 
post #4 of 6 (permalink) Old 09-18-2018, 05:12 PM
Forum Regular
 
Join Date: Apr 2011
Location: Texas
Posts: 73
Definitely an alternator issue.
stower17 is offline  
post #5 of 6 (permalink) Old 09-18-2018, 05:13 PM
Forum Regular
 
Join Date: Apr 2011
Location: Texas
Posts: 73
Oops didn't see your updated! Even better if it's just the belt!
stower17 is offline  
post #6 of 6 (permalink) Old 09-21-2018, 06:26 PM
Newcomer
 
808slowbalt's Avatar
 
Join Date: Aug 2018
Posts: 8
Another quick way to check if it is indeed the alternator, which is sounds like (from experience), is to have the car on and pull the battery cables off. If the car dies or jolts or loses voltage it's the alternator or alternator wiring. My personal experience was kind of like yours, but when I got it tested it wasnt showing anything abnormal. But it would do it once in awhile. These high output alternators tend to gradually go out rather then just blah done and gone. I vote alternator as well
808slowbalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome