05 Cobalt Acceleration Issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-23-2019, 10:05 AM Thread Starter
Newcomer
 
Join Date: Feb 2019
Posts: 1
05 Cobalt Acceleration Issues

I have a 2005 LS that is having issues with acceleration when it is cold outside. I am relatively new to doing my own repairs and am looking for suggestions to see if this is something I can fix on my own.

When the weather gets to about 30 degrees or so, I have to let the car warm up for 5 or 6 minutes before I can get any kind of acceleration. The engine revs up and runs, but I just creep forward. Once it gets warmed up there are no issues at all. If the weather is warm, there are no problems. I had my transmission looked at last fall and it was fine.

Any idea what might be causing this and is it something a motivated novice can fix? Thanks!
Brinkmas is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Cobalt LS Problem with Acceleration/lack of Power/hard Shifting Cshoffie Problems and Service 9 08-13-2012 06:56 PM
'05 Cobalt Ignition Issues and Questions splaudiohz Problems and Service 1 07-15-2012 01:03 PM
05 LS Vs 05 LT MyCobalt1127 Problems and Service 5 03-05-2012 05:06 AM
05 Balt,loss of Power on Acceleration. 56pontiac Chevy Cobalt Owners Lounge 3 10-20-2009 12:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome