Crank no start - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-23-2019, 12:49 PM Thread Starter
Newcomer
 
Join Date: Apr 2019
Posts: 5
Crank no start

I have a 2007 cobalt supercharged 2.0 just brought it about a week ago. Just wondering when I try to start it, it crank sometimes itll backfire when it doesnt start but when it eventually do start it runs and drives fine. Any advice on where to start. Fuel pump comes on I emptied all the gas just incase it was dirty. Changed the filter as well. The codes in it was b1325 and that's it besides p2229. It was missing the baro sensor so I replaced it.
Handheldace is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-26-2019, 12:57 AM Thread Starter
Newcomer
 
Join Date: Apr 2019
Posts: 5
So far checked for vacuum leaks which there arent any. Checked fuel pressure held at 60 psi. Injector pulse. Made sure injectors actually sprayed as well. Checked spark from each coil which was fine. Only thing out of the ordinary was loose plugs so I'll try and fire it up in the morning if still giving the same problem next thing is compression...
Handheldace is offline  
post #3 of 7 (permalink) Old 04-26-2019, 04:51 PM
Initiate
 
Join Date: Mar 2017
Posts: 48
DTC B1325 is a device low voltage code. Is your battery ok? Did you check compression yet? No other dtcs? Loose plugs will cause a issue due to blowing the compression out

Last edited by TCSS07; 04-26-2019 at 04:58 PM.
TCSS07 is offline  
 
post #4 of 7 (permalink) Old 04-29-2019, 06:33 PM Thread Starter
Newcomer
 
Join Date: Apr 2019
Posts: 5
Sorry just checked the thread but yeah check compression 1 was the lowest 170 and 4 the highest 210 besides that I think 2 was 200 and 3 was 190 so didnt seem too bad
Handheldace is offline  
post #5 of 7 (permalink) Old 04-29-2019, 06:35 PM Thread Starter
Newcomer
 
Join Date: Apr 2019
Posts: 5
Also tried using a valve cleaner thought maybe sticking valves... only other thing I did notice was I'd I give it high (really high about 5.5k rpms) white smoke comes through the exhaust
Handheldace is offline  
post #6 of 7 (permalink) Old 04-29-2019, 07:05 PM Thread Starter
Newcomer
 
Join Date: Apr 2019
Posts: 5
Another thing just noticed after driving for a while once the engine warm up it usually start without a problem
Handheldace is offline  
post #7 of 7 (permalink) Old 04-29-2019, 07:44 PM
Initiate
 
Join Date: Mar 2017
Posts: 48
i dont know if my pm went through so ill post here also.

all good on the response. Pm is the best way to get a hold of me since i dont check everyday. I have a lsj as well and honestly ive never done a compression check so i dont know what the base line number should be but id usually like to see them closer together given there is a 40psi difference between highest and lowest reading. how many miles are on the engine? white smoke blowing out isnt a good sign however what kind of valve cleaner are we talking about because those can cause white smoke and shit until you burn it all out if you use one that goes through the induction system rather than the fuel system. do you have a cylinder leakage tester? you had no others dtc's right? and do you have access to a scanner that can see data? like misfire counts and stuff
TCSS07 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Cobalt No Crank No Start No Ecm Communication 1tjizzle Problems and Service 0 02-22-2019 11:56 AM
No crank no start no tail lights power steering message Bambrewer Problems and Service 3 03-04-2018 08:35 PM
Cobalt stalled, would crank but no start. Now no crank no start. Lord Sagat Problems and Service 4 09-06-2017 09:01 AM
08 Cobalt No Crank No Start Luis Vasquez Problems and Service 6 05-23-2017 01:16 PM
Intermittent No Start, No Noise, No Lights on Dash, No Power to Clock or Radio brittany713h Problems and Service 5 11-23-2013 08:06 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome