Speedometer Backlight Out - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-18-2019, 12:48 PM Thread Starter
Newcomer
 
Join Date: Jul 2018
Location: Airdrie, AB
Posts: 6
Speedometer Backlight Out

The speedometer backlight on my 2007 Cobalt LT is out. The fuel and tach gauges are still backlit, just not the speedometer. I don't think it is a fuse problem, because it would be the whole cluster that would be dark, correct? Did some quick Googling on speedometer-specific light problems, with no success. Hoping someone here has seen this before. Are the bulbs in behind the cluster easy enough to replace myself? I see a couple screws around the cluster that I almost took off yesterday to start poking around... I just don't want to get in too deep before knowing what kind of trouble I can potentially get into!

Don't know if this is related or not, but I also noticed recently that the driver side half of the trunk brake light does not light up. Passenger side is fine.
RJohnson is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-16-2019, 12:04 PM
Newcomer
 
Join Date: Jul 2019
Location: Detroit, MI
Posts: 2
I have a 2010 Cobalt and am experiencing almost exact same issue. My tail lights also don't work nor do the little marker lights on the bottom of the tail light assembly. Replaced all bulbs with new and still no tail lights. Brakes and turn indicators work fine. The PRK Lamp fuse blows (10A) every time I turn on the headlights.

Did you resolve your issues?
Charles H Lewis is offline  
post #3 of 4 (permalink) Old 07-17-2019, 07:16 AM Thread Starter
Newcomer
 
Join Date: Jul 2018
Location: Airdrie, AB
Posts: 6
Quote:
Originally Posted by Charles H Lewis View Post
I have a 2010 Cobalt and am experiencing almost exact same issue. My tail lights also don't work nor do the little marker lights on the bottom of the tail light assembly. Replaced all bulbs with new and still no tail lights. Brakes and turn indicators work fine. The PRK Lamp fuse blows (10A) every time I turn on the headlights.

Did you resolve your issues?
No, haven't tried to tackle the cluster light yet. I found a YouTube vid on replacing the trunk light bar bulbs. Very easy. I have a week off work coming up where I plan to open up the cluster to get at the speedometer back light. I'll let you know if I have any success.

I don't know about your issue. Sounds like a short circuit or crossed wire somewhere. I am definitely not the right person to give electrical advice, though!
RJohnson is offline  
 
post #4 of 4 (permalink) Old 08-04-2019, 11:27 AM
Forum Regular
 
Join Date: Apr 2011
Location: Texas
Posts: 73
The gauge cluster uses LED bulbs, I am almost positive about that. This would be the first time I’ve heard of a bulb failure in the cobalt gauge cluster, it’s possible you have a faulty gauge cluster or a burnt out bulb. You can send it out for repair, there is a whole cottage industry that repairs GM gauge clusters.
stower17 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
backlight , cluster , dash , speedometer

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome