Popping noise on take off - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-26-2019, 10:50 AM Thread Starter
Newcomer
 
07lswk's Avatar
 
Join Date: Jun 2019
Posts: 2
Popping noise on take off

I own a 2007 Cobalt LS 2.2 w/ manual transmissionLast weekend i replaced struts inner + outer tie rod ends sway bar links and sway bar bushings lower control arms with ball joints and bushings and new [not refurb] cv axles and got an alignment.. The noise doesn't happen everytime I take off from a stop and I dont drive it like a race car so just a normal take off and I am getting a popping from what sounds like the front end. I've been to 2 different shops and neither one can find the issue. Somebody please drop some knowledge for me it would be very much appreciated.
07lswk is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-03-2019, 03:09 PM
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 102
Garage
Mine does the same issue but it’s more like a creak noise I’ve done all that to my car and I think it’s something with the struts

CEEJBRO!!
email
[email protected]
Macky91 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome