2005 SS/SC No Start/No Crank/No Radio? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-27-2019, 03:01 AM Thread Starter
Newcomer
 
Join Date: Apr 2018
Location: Battle Creek, MI
Posts: 3
2005 SS/SC No Start/No Crank/No Radio?

So I started having this issue a few days ago. Car was running one day, parked it for the night and now it wont start. Checked and noticed the battery voltage was low(9v), so I replaced the battery but that didn't seem to fix the issue.

When I turn the key, all the lights come on, and it seems normal but the car wont even try to crank. Almost like the clutch isn't pressed. I've heard about issues the clutch sensor(s), and need to know how exactly I should be checking them.

There is one odd thing. The radio won't ever light up or turn on? It is an aftermarket head unit that turned on just fine before, but now nothing. I'm wondering if this could somehow be related to the issue I'm having.

The key-less entry fob also wont do anything, I press any of the buttons and nothing happens. No lock, no unlock, no panic beeping, and no trunk.

I get 12+volts between the post and ground under the hood, the interior lights come on, dash lights come on, and the climate control blower works so I am getting power to the car.
Karnage219 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome