2005 Chevy Colbalt 2.2L Spark Plug Problem! - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 12-17-2009, 06:31 PM Thread Starter
Contributor
 
Join Date: Nov 2009
Posts: 489
2005 Chevy Colbalt 2.2L Spark Plug Problem!

I went to change the spark plugs on my car and the place I bought them sold me ones too short.



*Now the actual problem: I put the car back together with the old plugs back in, for some odd reason there is a loud knock when started for a couple of seconds then it stops.*

*Edit* I lost one of the coil pack bolts so is that the problem?*Edit*
darklide is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 12-17-2009, 06:34 PM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
did the bolt fall in the head? LOL kinda a silly question but that could explain why the bolt's gone and there's noise!

the ngk looks like a plug for my engine (lsj) weird looking gap and thread on the acdelco plug. kinda confused.

ff_drift_lol is offline  
post #3 of 21 (permalink) Old 12-17-2009, 06:35 PM Thread Starter
Contributor
 
Join Date: Nov 2009
Posts: 489
Quote:
Originally Posted by ff_drift_lol View Post
did the bolt fall in the head? LOL kinda a silly question but that could explain why the bolt's gone and there's noise!

the ngk looks like a plug for my engine (lsj) weird looking gap and thread on the acdelco plug. kinda confused.
No lost the bolt near the headlight.
darklide is offline  
 
post #4 of 21 (permalink) Old 12-17-2009, 06:39 PM
 
Join Date: Oct 2009
Location: Maryland
Posts: 1
I use Pulsar pulse plugs
eldogo is offline  
post #5 of 21 (permalink) Old 12-17-2009, 06:40 PM Thread Starter
Contributor
 
Join Date: Nov 2009
Posts: 489
Now this sound even more stupid, but the alarm went off so I had to crank the car to shut it off, now there was no coil pack plugged in, and one spark plug missing, so did any engine damage occur? Or did it just dump fuel into the engine?
darklide is offline  
post #6 of 21 (permalink) Old 12-17-2009, 06:40 PM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
what do you mean by knocking noise? knocking is supposed to mean timing knock retard, do you mean like a hollow deep knocking sound? rattling? it's hard to tell over the interwebz

^it wouldve just dumped fuel

ff_drift_lol is offline  
post #7 of 21 (permalink) Old 12-17-2009, 06:41 PM Thread Starter
Contributor
 
Join Date: Nov 2009
Posts: 489
Quote:
Originally Posted by ff_drift_lol View Post
what do you mean by knocking noise? knocking is supposed to mean timing knock retard, do you mean like a hollow deep knocking sound? rattling? it's hard to tell over the interwebz

^it wouldve just dumped fuel
I guess more of a click, click noise?
darklide is offline  
post #8 of 21 (permalink) Old 12-17-2009, 06:43 PM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
this is from removing one plug and starting the engine? did you remove all 4 plugs? did you do anything else to the car while the plugs were out? how long does the noise last?

ff_drift_lol is offline  
post #9 of 21 (permalink) Old 12-17-2009, 06:44 PM Thread Starter
Contributor
 
Join Date: Nov 2009
Posts: 489
Is it the coil pack not making a total connection to the spark plugs so it's spark is jumping on startup and then making the noise?
darklide is offline  
post #10 of 21 (permalink) Old 12-17-2009, 06:45 PM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
oh so you're saying like an electrical noise like an arc?

ff_drift_lol is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome