I Dont Get It!!! Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 02-18-2010, 09:26 PM Thread Starter
Forum Regular
 
Bad05ss's Avatar
 
Join Date: Aug 2009
Posts: 94
I Dont Get It!!! Help

so about two days ago my safety switch on the clutch went out. so i unplugged it and jumped it to make it think it there all the time. had no problems out of it untill this morning, i go out and turn the key and nothing i look at the wire i use to jump it and it still there? i checked all the fuses and none are blown every thing work find to, but i notice that none of the indicators between the MPH and RPMs show up? i look on the connector where you plug it into the top of the switch and notice that one of he wire are cut, but slightly. might be hangin on by a few strans do you think that might be the gremlin?

---------- Post added at 09:26 PM ---------- Previous post was at 09:20 PM ----------

bump


Click the link below to check out our thread
Northern Virginia EcoTecs 48 Members/Guests. Interested?
Bad05ss is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-18-2010, 09:27 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
*Moved to Owners Lounge*




XFE is offline  
post #3 of 9 (permalink) Old 02-18-2010, 09:37 PM Thread Starter
Forum Regular
 
Bad05ss's Avatar
 
Join Date: Aug 2009
Posts: 94
sweet.............. i dont wanna move!


Click the link below to check out our thread
Northern Virginia EcoTecs 48 Members/Guests. Interested?
Bad05ss is offline  
 
post #4 of 9 (permalink) Old 02-18-2010, 09:39 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Quote:
Originally Posted by Bad05ss View Post
sweet.............. i dont wanna move!
As for your problem...i have no clue.

IM still thinking..




XFE is offline  
post #5 of 9 (permalink) Old 02-18-2010, 09:40 PM Thread Starter
Forum Regular
 
Bad05ss's Avatar
 
Join Date: Aug 2009
Posts: 94
its weird idk


Click the link below to check out our thread
Northern Virginia EcoTecs 48 Members/Guests. Interested?
Bad05ss is offline  
post #6 of 9 (permalink) Old 02-18-2010, 09:42 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
That wire being cut could be your problem...




XFE is offline  
post #7 of 9 (permalink) Old 02-18-2010, 09:47 PM
Expert


 
Philswrath's Avatar
 
Join Date: Jan 2010
Location: San Antonio
Posts: 867
Garage
i would say try and splice it back together, and wrap it with some electrical tape,and take it to a dealler or shop but then again, this is only what i would do, me having some electrician friends and all, so.....do it at your own risk lol

unless of course you find something else, or just get it towed to get it fixed

Quote:
Originally Posted by Cobaltxfe09 View Post
:bangs****ingheadagainstthewall: :throwshandsupindisgust: i give up...lol
this is when mike decided to give up his balt ^^

http://s4.zetaboards.com/Cobalt_Universe/index/
Philswrath is offline  
post #8 of 9 (permalink) Old 02-19-2010, 12:59 AM
Levee
YourCobalt of the Month Winner
YourCobalt.com Premium Member
Admin


 
Leveecius's Avatar
 
Join Date: Aug 2009
Location: Battle Creek, MI
Posts: 3,210
Garage
Send a message via Yahoo to Leveecius
Are you talking about your neutral safety switch?

'09 SS/TC - Stolen
Mods - Injen CAI, CIA MAF Relocate CP's, Dejon FMIC,
Custom 3" DP, 3" Exhaust, GT3076R, Pioneer AVH-4100DVD, Hurst STS, ZZP triple pod, Autometer Cobalt boost/DPIC/WB gauges, Nitto NT05 245/40/18's, H&R Springs, 80:20 Meth Spray
Future - KSport Kontrol Pro Coilovers, 10% Tint, FMIC spray
538whp/501wtq @38 psi on meth and 93 oct on stock ish motor


06 EVO IX MR/SE - Sold
Mods - *Updated 10/6/13* AEM TRUboost EBC, 4in custom TBE, SD dual 93/e85 tune, ETS 4in Race Core FMIC, Dual Aeromotive 400lph Fuel Pumps, T4 Tubular Manifold w/ dual WG's, FP Super99HTZ DBB Turbo, GSC 274 mivec cams, ARP headstuds/rod studs, FIC 2150cc Injectors, Aeromotive FPR, Aeromotive Fuel Rail, catch can, Mini Battery Kit, Slim Coolant Fan, Kiggly Racing high pressure valve Springs/Titanium Retainers, Supertech Stainless Steel Valves, Dual VTA Tial 44mm WG's, 4g64 Stroker Manley Pistons, 155mm 2.4 LR Manley Turbo Plus I Beam Rods with ARP 625 Studs, 100mm forged non-billet Manley Crankshaft, Full H/E PNP with Port Matching, Kiggly Racing Girdle, Dual Tial 50mm BOV's, Excedy Triple Disc Carbon HD Clutch, AEM EMS

'95 Ram 2500 Diesel
Mods - 5in TBE, Boost Elbow set to 28psi, Adjusted fuel pump, Open Turbo.

Future Mods- Super Street Clutch (rated @1400ftlbs tq), 67mm turbo, 160lb valve springs, added timing, tubular exhaust manifold, larger injectors, possible 6 spd swap.


Master ASE Certified Gasoline/Diesel Technician since 2004

Speed Junkies Social Group

Yourcobalt Official Facebook Page!

Syndicate of Tuners Official Page! Up and going again as of 1/11/13

Click here to PM me if you have questions or issues!
Leveecius is offline  
post #9 of 9 (permalink) Old 02-19-2010, 05:11 AM
Veteran
 
G5Steven's Avatar
 
Join Date: Oct 2009
Location: Lake Co. Florida
Posts: 674
Garage
Send a message via AIM to G5Steven
Need to get the switch replaced asap... that switch sending the signal all the time will throw codes and screw with your car... just ask my gf who likes to ride with her foot on the clutch. its the same concept as if you had your foot depressing the pedal all the time...

Last edited by G5Steven; 02-19-2010 at 01:23 PM.
G5Steven is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome