Seat Frame Poking Thru Foam - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-13-2010, 11:08 PM Thread Starter
Newcomer
 
Join Date: Oct 2009
Posts: 24
Seat Frame Poking Thru Foam

I have an 09 Cobalt four door. I have had issues with the seat frame on the side bolster break thru the foam. Had it fixed the first time and it has done it again. I was wondering if anyone else had this issue or am I just an elephant?
Captain Cobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-13-2010, 11:10 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Mine is doing this too....

---------- Post added at 02:10 AM ---------- Previous post was at 02:10 AM ----------

Drivers seat....right side of seat.




XFE is offline  
post #3 of 5 (permalink) Old 04-14-2010, 01:53 AM
Cobalt Specialist
 
Nighthawk243's Avatar
 
Join Date: Mar 2010
Location: Pittsburgh, Pistolvania
Posts: 1,218
Garage
Warranty. It shouldn't be doing it though. I'm 220 and I havn't had an issue with either the 05 or my old 07.


GM Stage II | 2nd Gen Projectors | 5000K Low Beams | 3000K HID Fogs | LED Tails| SS/TC Seats
▲RIP 2007 G5: Totalled 1/26/10▲
Nighthawk243 is offline  
 
post #4 of 5 (permalink) Old 04-14-2010, 06:29 AM
Not justice...Punishment
Staff Alumni
YourCobalt.com Premium Member


 
Will mpg's Avatar
 
Join Date: Sep 2009
Location: Brownsville, TN U.S.A.
Posts: 3,829
Garage
Should not happen. I am 275, and no issues with mine. I would take it back to them again. Maybe there is a sharp spot on the frame.

Will mpg is offline  
post #5 of 5 (permalink) Old 04-14-2010, 08:33 PM
Forum Regular
 
cr8054's Avatar
 
Join Date: Mar 2010
Location: North Jersey
Posts: 56
Garage
Quote:
Originally Posted by Captain Cobalt View Post
I have an 09 Cobalt four door. I have had issues with the seat frame on the side bolster break thru the foam. Had it fixed the first time and it has done it again. I was wondering if anyone else had this issue or am I just an elephant?
I had that problem with my '06 coupe. Had the seat back changed out once. I think its just a poor design.
cr8054 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome