Fault Code Po411 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-17-2010, 11:34 AM Thread Starter
Newcomer
 
Join Date: Feb 2009
Location: Wilmer Alabama,(near Mobile)
Posts: 3
Fault Code Po411

I keep getting a po411 fault code showing up,has to do with cold start air intake,I have a K&N filter,and it started doing it after last filter cleaning,08 Cobalt, any ideas?
ace26dan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-17-2010, 11:36 AM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
That code is something to do with the SAI (secondary air injection)

Maybe a fuse or relay for the SAI or you sucked water up into the SAI tube.

ECM
-P0411 - Means youre secondary isnt flowing enough, could be stuff in the tubes, air pump inop(blown fuse or water in pump are common)




XFE is offline  
post #3 of 3 (permalink) Old 04-27-2010, 06:49 AM Thread Starter
Newcomer
 
Join Date: Feb 2009
Location: Wilmer Alabama,(near Mobile)
Posts: 3
po411

pump is working,I can hear it again on a cold start,however light tripped again,took the relay out,that triggered a different code for faulty relay,put relay back in,pump works on cold start,po411 tripped again,I took the entire solenoid off,took it apart,it had water in it,cleaned all carbon build up off with carb cleaner,sprayed plunger good with motor-kote,let it soak for a while,re-assembled,and no light on cold start,and pump is still working fine,so hopefully problem is solved,will know for sure over the next day or so,if it comes back,I feel like the problem lies in the solenoid.......agree?,,thanks for the accurate advice

Dan
ace26dan is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome