Engine Surge - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-10-2010, 10:53 AM Thread Starter
Newcomer
 
Join Date: May 2010
Posts: 2
Engine Surge

Not really sure what's wrong with it. I just changed the air filter, spark plugs, and the wires. It still surges. When I turn it on and sometimes at a stop, it will go to REALLY low RPMs then go right back up, then sometimes cut off. Only other things I can think of is this hose I found in the front. Does anybody know what this hose is?
https://www.yourcobalt.com/forums/mem...e3826-hose.jpg
portvegas is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-10-2010, 02:16 PM
Veteran
 
rayray's Avatar
 
Join Date: Mar 2009
Location: Mayville WI
Posts: 567
Garage
vent hose



Mods:
Aeroforce Interceptor gauge, Eibach Sportlines, De-badged, 140 mph White Face Gauge Cluster, Silver Star Ultra Headlights, Injen CAI, CF Dash Trim, 5 Spoke Rims, Eibach 25mm Rear Sway bar, SS Upper Grille, Painted Black Bowtie, DC Sports Carbon Strut Bar, Injen Hydro-shield, Emergency Brake Boot, Blue Powdercoated Valve Cover, Black Dash & Center Council, Tsudo Catback, ZZP Downpipe.
rayray is offline  
post #3 of 6 (permalink) Old 05-10-2010, 02:28 PM
Yay go me
YourCobalt.com Premium Member


 
Punk's Avatar
 
Join Date: Oct 2009
Location: Johnstown
Posts: 2,154
Just get one for a junk yard and replace it

My sig thanks to Gcobalt
Punk is offline  
 
post #4 of 6 (permalink) Old 05-10-2010, 04:09 PM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
pcv hose. it connects to the intake after the mass airflow sensor. idle is fluctuating because there is more air going into the engine than the maf is detecting. simple. just patch it up. replace it, whatever. just make sure no air gets in or out after the maf sensor.

ff_drift_lol is offline  
post #5 of 6 (permalink) Old 05-10-2010, 04:18 PM
Yay go me
YourCobalt.com Premium Member


 
Punk's Avatar
 
Join Date: Oct 2009
Location: Johnstown
Posts: 2,154
i have one

---------- Post added at 04:18 PM ---------- Previous post was at 04:18 PM ----------

in my shied

My sig thanks to Gcobalt
Punk is offline  
post #6 of 6 (permalink) Old 05-10-2010, 08:05 PM
Cobalt Specialist
 
Join Date: Nov 2007
Location: Sunshine State
Posts: 1,250
Damn that hose looks old and oil soaked! Do you have a CEL? If you get a chance take it to autozone (or auto parts house) where they can read the codes to tell you if something has been picked up by the ECM.

Ex-Cobalt Owner
Red07SSNA is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome