O2 Sensor B.S - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-06-2010, 02:22 PM Thread Starter
Forum Regular
 
foxcobaltss's Avatar
 
Join Date: Jan 2010
Location: MN
Posts: 137
Angry O2 Sensor B.S

My check engine light came on last night so I read the code today and it was the running rich/bank 1 senor 1 exhaust manifold O2 senor code. I just replaced it last year with the OEM ACdelco O2 sensor, what BS huh?
foxcobaltss is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-06-2010, 02:38 PM
Cobalt Specialist
 
BlueFlash's Avatar
 
Join Date: Mar 2010
Location: Ohio
Posts: 1,056
Garage
do you know the specific CEL code? bc my code is p0107 which is MAP sensor, but when i got it checked the guy at autozone said it was the O2 sensor


2006 Laser Blue LS - Wrecked
BlueFlash is offline  
post #3 of 9 (permalink) Old 06-07-2010, 06:15 PM Thread Starter
Forum Regular
 
foxcobaltss's Avatar
 
Join Date: Jan 2010
Location: MN
Posts: 137
yes I know, I have a OBD-II scanner
foxcobaltss is offline  
 
post #4 of 9 (permalink) Old 06-07-2010, 06:18 PM
Expert


 
golfin's Avatar
 
Join Date: Jul 2009
Location: Abbotsford, British Columbia
Posts: 992
Garage
Send a message via Skype™ to golfin
have you done anything to your car recently?

golfin is offline  
post #5 of 9 (permalink) Old 06-07-2010, 06:55 PM
Cobalt Specialist
 
BlueFlash's Avatar
 
Join Date: Mar 2010
Location: Ohio
Posts: 1,056
Garage
yeah like did the code just come on? or have you done any mods recently that would affect the sensor? cuz the sensor would be fine if its just pulling in the code and not whats causing the car to run rich


2006 Laser Blue LS - Wrecked
BlueFlash is offline  
post #6 of 9 (permalink) Old 06-07-2010, 08:31 PM Thread Starter
Forum Regular
 
foxcobaltss's Avatar
 
Join Date: Jan 2010
Location: MN
Posts: 137
No, thats the weird thing haven't changed anything in a while
foxcobaltss is offline  
post #7 of 9 (permalink) Old 06-08-2010, 04:15 AM
Veteran
 
G5Steven's Avatar
 
Join Date: Oct 2009
Location: Lake Co. Florida
Posts: 674
Garage
Send a message via AIM to G5Steven
check other things first... Go through the list of why it would run rich, before fearing an O2 sensor. My Fiance's Grand Am kept throwing a P420 code and everyone knows either bad Rear O2 or bad Cat converter. Well I never thought of the TPS being faulty, but the run down of the reasons why a P420 would be thrown shows faulty TPS as the LAST thing to check. So I just let it go, then last weekend, it threw a new code for Faulty TPS (dunno the number) and when I took the TPS off to see, it was loose and sounded like parts broke inside. Threw a new on on and all is good.

Just check other sensors and parts out before fearing the O2 sensor. A diagnostic procedure is your best friend.
G5Steven is offline  
post #8 of 9 (permalink) Old 06-10-2010, 03:24 AM
Newcomer
 
Join Date: Dec 2005
Posts: 9
I agree I just got my girlfriend a cobalt LS and changed the air filter and it threw a po340 code which is a cam sensor. Come to fin out it was just some dust that got into the MAF sensor causing it. Cleaned it out and all is well.

Weapon-R intake, 17 silver wheels. Custom 2 1/4 in exhaust. Voltage regulator.
newcobalt06 is offline  
post #9 of 9 (permalink) Old 06-10-2010, 08:32 AM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
if you get a p0135 i'd blame the sensor. it's most likely being caused by something else.

ff_drift_lol is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome