Code P0340 ??? Any Ideas - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-11-2010, 07:47 PM Thread Starter
Newcomer
 
Join Date: Dec 2005
Posts: 9
Code P0340 ??? Any Ideas

I just bought my girlfriend a 2006 ls with an auto. I just changed the plugs, oil, and charged the AC. I took the air filter out to check it and it was clean so I put it back in. Well after driving for 20 minutes the check engine light came on. I took it to autozone and thier reader says it is a p0340 code which is for a cam sensor. I did change the oil to 5w-20 but don`t think that caused it. I cleaned the MAF sensor and it went away for a day but is back on now. Any ideas

Weapon-R intake, 17 silver wheels. Custom 2 1/4 in exhaust. Voltage regulator.
newcobalt06 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-11-2010, 08:23 PM
Banned


 
Join Date: Feb 2009
Location: Mechancisburg, PA
Posts: 7,805
Send a message via AIM to camopaint0707
ok well weapon r intake could be an issue, not sure why you need a regulator, and correct me if I'm wrong but this car runs 5w30 rightt?t?



camopaint0707 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome