Center A/C Vents Not Working. - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-22-2010, 02:28 PM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 62
Center A/C Vents Not Working.

I have a 2008 Chevrolet Cobalt. The two air conditioning vents in the middle of the front are not blowing air at the same rate as all the other vents. All four speed settings work fine on the other vents but not on the two in question. Could this be a motor issue, or could something be caught in the vent area preventing the air from going through? I just noticed the problem today but don't recall there being a problem before today.
cobalt3365 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-24-2010, 08:47 AM
Forum Regular
 
cr8054's Avatar
 
Join Date: Mar 2010
Location: North Jersey
Posts: 56
Garage
Quote:
Originally Posted by cobalt3365 View Post
I have a 2008 Chevrolet Cobalt. The two air conditioning vents in the middle of the front are not blowing air at the same rate as all the other vents. All four speed settings work fine on the other vents but not on the two in question. Could this be a motor issue, or could something be caught in the vent area preventing the air from going through? I just noticed the problem today but don't recall there being a problem before today.
Had the same problem with my 06 coupe. A piece of foam rubber came off a piece of the HVAC system that directs air flow. Was fixed under warranty.
cr8054 is offline  
post #3 of 8 (permalink) Old 06-24-2010, 01:07 PM
Cobalt Specialist
 
Nighthawk243's Avatar
 
Join Date: Mar 2010
Location: Pittsburgh, Pistolvania
Posts: 1,218
Garage
Unless you drive the balls off the car, it should be a warranty fix for a 08.


GM Stage II | 2nd Gen Projectors | 5000K Low Beams | 3000K HID Fogs | LED Tails| SS/TC Seats
▲RIP 2007 G5: Totalled 1/26/10▲
Nighthawk243 is offline  
 
post #4 of 8 (permalink) Old 06-24-2010, 01:50 PM
Contributor
 
Neddy06SS's Avatar
 
Join Date: Jun 2010
Location: DC Metro Area
Posts: 274
Send a message via Yahoo to Neddy06SS
I have a similar problem, only I barely feel ANY breeze from the vents unless I am 6" away from them. I have the fan on 4 but when I sit back, I cant feel ANY air.

2006 Cobalt SS 2.4L Auto
Stock 1/4: 16.315 @ 83.65 (104 degree day)
Facebook: rmikek
Neddy06SS is offline  
post #5 of 8 (permalink) Old 06-25-2010, 02:24 PM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 62
Quote:
Originally Posted by Nighthawk243 View Post
Unless you drive the balls off the car, it should be a warranty fix for a 08.
I bought the car in January. It was a former rental car with 46,000 miles, so the 3yr/36,000 warranty is a goner...
cobalt3365 is offline  
post #6 of 8 (permalink) Old 06-25-2010, 02:36 PM
Forum Regular
 
Join Date: Jun 2010
Posts: 224
that isnt hard to check if you want to

cobalt123 is offline  
post #7 of 8 (permalink) Old 06-25-2010, 07:08 PM
Newcomer
 
Join Date: Dec 2007
Posts: 22
check cabin filter... im pretty sure the 2inches of buildup on mine killed my hvac motor at 160k miles

05 Base ATX, sedan, stock, blue granite, 151k miles
mattjordan is offline  
post #8 of 8 (permalink) Old 06-27-2010, 04:11 PM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 62
I replaced the cabin filter. The center left vent is pushing more air but the center right is still dead. So there is some progress...
cobalt3365 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome