Cruise Control Switch - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-10-2010, 09:10 AM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Cruise Control Switch

So my cruise control only works in a great while or when it wants to. Sometimes ill turn the switch on then go to set it and it works fine, then other times it wont set. Im about to replace the Set/Resume switch. Do you guys think thats what my problem is?

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-10-2010, 02:36 PM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Bump!

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
post #3 of 10 (permalink) Old 08-10-2010, 08:19 PM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Anyone? ideas?

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
 
post #4 of 10 (permalink) Old 08-10-2010, 08:20 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
That could be your problem. I've had those go bad on my past cars. My cobalt doesn't have it. So ya....haha




XFE is offline  
post #5 of 10 (permalink) Old 08-10-2010, 08:29 PM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Quote:
Originally Posted by XFE View Post
That could be your problem. I've had those go bad on my past cars. My cobalt doesn't have it. So ya....haha
Ok, its only $11 bucks. just thought I would get some input.

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
post #6 of 10 (permalink) Old 08-10-2010, 08:31 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Get it, more than likely if it's intermittent like that...it's probably it.




XFE is offline  
post #7 of 10 (permalink) Old 08-10-2010, 08:34 PM
Contributor
 
Chuck0781's Avatar
 
Join Date: Apr 2010
Location: Chardon Ohio
Posts: 489
Garage
My dad's 06 G6 did the same thing. They replaced that switch two months back and no problems since.

LIVE LOVE BURN DIE

My Sig thanks PADLOCK
No one knows what is going on! Its just a simple answer with a complex conclusion
Chuck0781 is offline  
post #8 of 10 (permalink) Old 08-10-2010, 08:41 PM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Quote:
Originally Posted by Chuck0781 View Post
My dad's 06 G6 did the same thing. They replaced that switch two months back and no problems since.
Lol! I changed a switch at work yesterday in a 07 G6. Thats what made me realize that might be my problem.

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
post #9 of 10 (permalink) Old 08-10-2010, 08:44 PM
Contributor
 
Chuck0781's Avatar
 
Join Date: Apr 2010
Location: Chardon Ohio
Posts: 489
Garage
Well its the G6 curse lol! Hope its your problem though a quick cheap fix!

LIVE LOVE BURN DIE

My Sig thanks PADLOCK
No one knows what is going on! Its just a simple answer with a complex conclusion
Chuck0781 is offline  
post #10 of 10 (permalink) Old 08-10-2010, 08:46 PM Thread Starter
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
Ok thanks guys! Im gonna get one then.

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome