Car is Undergoing Major Problems Right Now! Please Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 11-13-2010, 12:24 PM Thread Starter
Forum Regular
 
litalien18's Avatar
 
Join Date: Dec 2009
Posts: 107
Garage
Car is Undergoing Major Problems Right Now! Please Help

So it all started on a very cold night about two weeks ago. My car is kept in a garage every night, but on this night i was staying at my girlfriends so it had to manage to spend the night out in the 30 degree weather. When i got up in the morning and was just about to leave for work, my car wouldnt start? Hmm... weird ive never had to jump my car in the long year ive had it. So that night i put the car in my garage, and around 11pm my dad calls me up and says my fog lights are on. I thought this was strange since my car had been off for several hours and i had made many trips out to the garage not noticing anything. I couldnt turn the fog lights off just by pressing the button so i started the car(which surprised me) and then the turned off. The next morning i had to get another jump. I stopped using my fog lights, and for a couple of days my car worked fine. Last night i turned my fogs on just as a test. Everything worked fine on my way home from work. AFter i got home i drove to pizza hut to get food with my girlfriend, then i realized my right headlight is not working. I got home and put it in the garage. Later that night(around 11pm again) my mom said my cars lights were flickering and whatnot, but i was not in a good mood so just ignored it till this morning. Car doesnt start again. i am charging my battery right now. When i first hooked up the charger it said my battery was very low, but now after a hour its got a full charge? My dad said this is not right, because it would take hours for a dead battery to charge full. Is it just a bad battery with bad cells? Or could it be my alternator? Whats going on? Will i ever be able to use my fogs again without draining my battery. I do have hid's both on my heads and fogs by the way.

2007 Chevy Cobalt SS Supercharged Black
~ Gen 3-8000 HID's and Fogs, Borla Exhaust System, K&N Typhoon Intake, Powder Coated Rims, Kenwood In-Dash 7" Monitor.
Photobucket
litalien18 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-13-2010, 12:30 PM
Forum Regular
 
Bumble_Bee's Avatar
 
Join Date: Oct 2010
Posts: 70
Sounds like your car is possessed! I kid!

I'm not sure really, my guess it's battery?
Bumble_Bee is offline  
post #3 of 10 (permalink) Old 11-13-2010, 12:39 PM
Not justice...Punishment
Staff Alumni
YourCobalt.com Premium Member


 
Will mpg's Avatar
 
Join Date: Sep 2009
Location: Brownsville, TN U.S.A.
Posts: 3,829
Garage
1st thing is to address the simplest thing. Take the battery to an autoparts store and have them check it for bad cells.

Will mpg is offline  
 
post #4 of 10 (permalink) Old 11-13-2010, 12:40 PM
Veteran


 
dkscbalt's Avatar
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 527
Send a message via Yahoo to dkscbalt
Wow man you have a nasty electrical issue


Built not bought fully bolted 2.2 and Trifecta Tuned

Authorized Trifecta Reseller In Central Wisconsin

Check out my new showoff thread!!!
https://www.yourcobalt.com/forums/veh...entral-wi.html
dkscbalt is offline  
post #5 of 10 (permalink) Old 11-13-2010, 02:29 PM Thread Starter
Forum Regular
 
litalien18's Avatar
 
Join Date: Dec 2009
Posts: 107
Garage
I think i might have fixed it for now... we'll see though. I took off my fog light hid's and put on the stock lights. When i was doing so i noticed the bolt on my fuse box holding down the power cords was a little loose. I took off the power cord for my hid's and then tightened that baby down. So im gonna use my fogs all day today and then see if my car starts up tomorrow morning. If not i will be takin my battery in like you suggested Will mpg. Thanks guys

2007 Chevy Cobalt SS Supercharged Black
~ Gen 3-8000 HID's and Fogs, Borla Exhaust System, K&N Typhoon Intake, Powder Coated Rims, Kenwood In-Dash 7" Monitor.
Photobucket
litalien18 is offline  
post #6 of 10 (permalink) Old 11-13-2010, 03:38 PM
Not justice...Punishment
Staff Alumni
YourCobalt.com Premium Member


 
Will mpg's Avatar
 
Join Date: Sep 2009
Location: Brownsville, TN U.S.A.
Posts: 3,829
Garage
Hope it works out... Let us know.

Will mpg is offline  
post #7 of 10 (permalink) Old 11-13-2010, 05:25 PM
Forum Regular
 
88keys's Avatar
 
Join Date: Jul 2009
Posts: 108
Could be a bad fog light relay? Maybe the HIDs pulled too much current and damaged the relay. I'm taking a wild guess here.


'08 Cobalt LS Coupe Victory Red | Showoff Thread
88keys is offline  
post #8 of 10 (permalink) Old 11-13-2010, 05:44 PM
Forum God


 
4dr-LS's Avatar
 
Join Date: Aug 2009
Posts: 2,099
Garage
wow, you have the dreadful "demon car" that every shop hates to work on lol good luck on getting it fixed though

R.I.P. :(

Hello
4dr-LS is offline  
post #9 of 10 (permalink) Old 11-14-2010, 06:28 AM
Forum Regular


 
DALLAS_CB's Avatar
 
Join Date: Jul 2009
Location: North Idaho
Posts: 195
Garage
You could also check your wiring and make sure nothing has rubbed so badly that the wires are grounding out somewhere....

DALLAS_CB is offline  
post #10 of 10 (permalink) Old 11-15-2010, 09:59 AM
Forum Regular
 
Join Date: Jul 2010
Location: SW OK
Posts: 71
Quote:
Originally Posted by DALLAS_CB View Post
You could also check your wiring and make sure nothing has rubbed so badly that the wires are grounding out somewhere....
Yeah agree with the grounding issue, check all grounds. Have autozone preform a load check on your alt, and battery. If the alt, and battery checks out then check all the grounds going to those lights. If all look good and there's no issue with them, then it could be a relay. My nephew has the same problem on his 1992 Chevy C1500 we replaced all the grounds, the alt, the battery, and even all the relays. Come to find out it was his headlight switch, the highs wouldn't come on but the lows would, then when the highs did come on it would black out all his lights.. the switch was grounding out because it had a short.
BlkWolfCobalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome