Got This Werid Issue... - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-27-2010, 04:04 PM Thread Starter
Newcomer
 
Join Date: Nov 2010
Posts: 2
Got This Werid Issue...

So im losing coolant slowly i get a low coolant light every two or so weeks from driving.....and when i star my car it makes this clicking sound....no CEL or and no noticable perfornace issues i brought it to my dealer 2 times and they said they found nothing.....im at my wits end i dont know what it could be...
RisenCobaltSS is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-27-2010, 08:38 PM Thread Starter
Newcomer
 
Join Date: Nov 2010
Posts: 2
Anyone ?
RisenCobaltSS is offline  
post #3 of 6 (permalink) Old 11-27-2010, 08:48 PM
Get Out The Sawzall
Staff AlumniCobalt Master
 
DROPPEDATBIRTH's Avatar
 
Join Date: Apr 2010
Location: Sewickley, Pa
Posts: 1,856
Garage
DROPPEDATBIRTH is offline  
 
post #4 of 6 (permalink) Old 11-27-2010, 09:04 PM
Not justice...Punishment
Staff Alumni
YourCobalt.com Premium Member


 
Will mpg's Avatar
 
Join Date: Sep 2009
Location: Brownsville, TN U.S.A.
Posts: 3,829
Garage
Would be my guess... Do our water pumps have a weep hole?

Will mpg is offline  
post #5 of 6 (permalink) Old 11-28-2010, 06:23 AM
Forum Regular


 
DALLAS_CB's Avatar
 
Join Date: Jul 2009
Location: North Idaho
Posts: 195
Garage
My old taurus had similar problems. Turned out to be hairline cracks in the bottom of the plastic tank. I bought two tanks during the five years i had it. Never really trusted the whole pressure/heat in a plastic bottle theory.

DALLAS_CB is offline  
post #6 of 6 (permalink) Old 11-28-2010, 08:00 AM
YourCobalt of the Month Winner
YourCobalt.com Premium Member


 
LSlowBalt's Avatar
 
Join Date: Aug 2009
Location: Roaring Springs, PA
Posts: 1,429
Garage
Send a message via Yahoo to LSlowBalt
Water pump was my guess
any puddles where you park?
LSlowBalt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome