Door Lock Problems - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 01-11-2011, 08:19 PM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 100
Exclamation Door Lock Problems

Have had these problems for sometime now and i have not had time to figure it out. I have had an issue with my door locks locking and unlocking by themselves all the time it gets quite annoying hearing it all the time. It happens when i am driving and when i am out of the car. Could this be a fuse problem? Or perhaps a loose ground wire? Or any other suggestions i will probably be working on fixing this for most of the day tomorrow.
Yellowcobalt05 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 01-12-2011, 05:42 AM
Cobalt Specialist
 
krazedkitty's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 1,437
Garage
It could be either of those things you listed or possibly your body control module is going bad.
krazedkitty is offline  
post #3 of 17 (permalink) Old 01-12-2011, 06:00 AM
Forum Regular
 
Join Date: Sep 2010
Posts: 91
Send a message via AIM to Oldkid
My Cobalt unlocks the doors when the transmission in placed into park. There are several ways to program the lock and unlock that's explained in the owners manual. I guess it's possible for the switch that tells the system that you are in Park could be bad or out of adjustment but I would think the transmission indicator would show something.
You may want to program your car to a different lock/unlock program to see if the problem changes.
Best of luck, Tom
Oldkid is offline  
 
post #4 of 17 (permalink) Old 01-12-2011, 08:27 AM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 100
where is the ground wire for that anyway?
Yellowcobalt05 is offline  
post #5 of 17 (permalink) Old 01-12-2011, 02:07 PM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 100
Replaced the fuse today with another one. Haven't had anymore problems with it since but will take a while to see if it really fixed it considering sometimes it goes a while without doing it. Thanks for all the help everyone! Glad to be back on yourcobalt.com!

---------- Post added at 05:07 PM ---------- Previous post was at 05:06 PM ----------

Krazedkitty what kinda of headlight mods did you do to your cobalt?
Yellowcobalt05 is offline  
post #6 of 17 (permalink) Old 01-13-2011, 06:37 AM
Cobalt Specialist
 
krazedkitty's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 1,437
Garage
They're just stockers painted black. There's a how-to on here if ya want to know how to do it.
krazedkitty is offline  
post #7 of 17 (permalink) Old 01-13-2011, 07:41 AM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 100
oh okay they are cool looking how long did it take you? Oh and about the door problem i was driving last night and it was still doing it. So the fuse must have not been the problem but i stuck a brand new fuse in it last night do you know where the ground is for the door locks?
Yellowcobalt05 is offline  
post #8 of 17 (permalink) Old 01-13-2011, 08:21 AM
Cobalt Specialist
 
krazedkitty's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 1,437
Garage
Someone else actually painted them & I bought them that way, lol. If you're good at painting I don't think it'd take you too long. Getting them sealed-up right is the tricky part.

I have no clue about the ground, sorry. Hopefully someone else knows...
krazedkitty is offline  
post #9 of 17 (permalink) Old 01-13-2011, 08:57 AM Thread Starter
Forum Regular
 
Join Date: Feb 2010
Posts: 100
haha yeah i noticed that with the stock headlights i had the seal was really bad on those had to get them resealed when it was under warranty and still had to buy sealant from autozone but now they dont leak. The ground to the battery was kinda loose i dont know if they had anything to do with it.
Yellowcobalt05 is offline  
post #10 of 17 (permalink) Old 01-18-2011, 01:59 PM
Newcomer
 
Join Date: Mar 2010
Location: Michigan
Posts: 16
my car locks itself whenever i leave it running and close the doors... it gets expensive having someone come out and unlock it. ive replaced the fuse and checked all my grounds. everything looks good
bmxracerchamp12 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome